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Note that the flash upgrade program is incompatible with the serial ports of some
docking stations for laptops. In the event of problems using a docking station serial
port, please remove the laptop from the docking station, connect the upgrade lead

directly to the laptop, and try again.

Also please make sure that Microsoft ActiveSync is not installed on the PC/laptop. If

it is, please ask your technical support team to set up a new login for you.

Alternatively open Microsoft ActiveSync. Go to File option and select Connection

Setting. Make sure the check-box for “Allow connections to one of the following: “is

unchecked.
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Section 1: Introduction

This document is written to facilitate Palmer Client to upgrade Patroller Firmware via
the serial communication interface with Patroller Interface Unit and the User’s

computer.

Please note that a serial port must exist on the PC/laptop. If a laptop is to be used,
please  remove it from the docking unit before  continuing.
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Section 2: Required Files & Equipments

Required Equipments:

1. Patroller Interface Unit (with battery)
2. Palmer provide Firmware upgrade cable

3. PC/Laptop

Required Files:

Patroller Interface Unit Firmware Upgrade Required Files.

@ patrollerFirmwareUpgrade

File Edt View Favorites Tools Help /4

‘_) J I? ./ ) Search i Folders --

Address (23 C:\Documents and Settings\Alaina_T\DesktopPatrollerFirmwareUpgrade v | Go

~
ccBrd028:x. dat o F281:xR5232Flash.dll
File and Folder Tasks & 3 05/04/2002 12:00 -& 01/09/200S 14:23
DAT File 1.0.0.2
7 Make a new folder -
&) Publish this Folder to _‘5‘ sdtsrvdl
the Web - |:.t.-l:|'l|.|||'_-.|.|'.|;. 14:30
fad Share this Folder l— 0.0
l 'I sdopts.c
-":’q l?_llrj.i'l_lllﬂfg.Tj'f-:'ﬁ-
Other Places Ci & Micrasoft Office Outlook Carfi...
(&} Deskop Ty Fog125enialFlash.out Patroller2_Flash_v1.04_20072
= [\:lllll_'4.|"_l_l:_ll-' 17:18 __’i:!llll_l|—_'.ll"_'l_ 07 15:42
u—} MY Dacuments @ QUT File QLT File
i My Computer
&3 My Network Places Y F28125erialFlash.sdp
29/06/2007 10:52
SDP File

Details v

This file will be the one to remove and replace whenever there a new version of firmware is available.

Figure 1: Required Files

The files shown in Figure I are required to complete the firmware upgrade process.

Note the circled red area in Figure I: This file is the actual firmware to be upgraded

into the Patroller Interface Unit and should be replaced with the new file.

Version number shown:

Patroller2_Flash v1.04_2007.out

Future release number should be:
Patroller2_Flash_vx.xx_uuuu.out
Where x.xx defines the version number and uuuu defines the year the firmware is

released.
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Section 3: Patroller Normal Operations & Upgrade Operations Procedures

Normal Operations:

The user should press the power button briefly to turn on or turn off the Patroller
Interface Unit.

On power on: LED:

On release of power button: LED , flashing every second.

Please wait 45 seconds for the LED to go green if LED goes from to RED.

(Please read Patroller User Manual for normal operations)

Upgrade Operations:

If firmware upgrade is required:

1. While power is off (the LED ( ) is not flashing), the user must hold the
power button down for about three seconds until the LED colour changes from

to RED.

2. After the LED goes RED, the user has 45 seconds to start the firmware
upgrade with the SDFlash program. After this time, the normal program
resumes operation. To continue with the flash operation if this stage is
reached, the user should return to step 1.

3. Follow the procedure in Section 4 & Section 5 to complete the upgrade

process

Successful Firmware Upgrade:

When communication is established (using SDFLASH) between the Computer/laptop
and the Patroller Interface Unit, erase, programme, verify will be activated between
the user computer/laptop and Patroller. LED will stay RED throughout the process.
When the process is completed, the power button should be pressed, and the unit will

resume normal operation with the new firmware in place.

Unsuccessful Firmware Upgrade:

Note that if Please make sure that this step is completed, if any changes required
between Step 5 to 8.

1.1. Go to File -> Save Project
1.2. See Figure 7.
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Flash.sdp - SDFlash
Buffer

Wiew  Project Device Window Help

IMew Project Chrl+M
Open Project... Chrl+0
Close Project

Save Project As..,

1 F2&125erialFlash,sdp
2 Fza125erialFlash.sdp
3 Fza125erialFlash.sdp
4 F2&125erialFlash.sdp

Exit

:’:IIMSG: Interface version 1

4 [ ¥ [%\ Programming Flash { Loader /

Save the active project l_ ’W ’_ /A
Figure 7: File save Project after changes to SDFLASH Utility
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Section 5 is not completed, normal Patroller operation resumes after 45 seconds. LED
will be flashing . In this case, the firmware upgrade has failed or not

commenced within the 45 second time windows while the LED was RED.
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Section 4: SDFlash Utilties Screens Check

This setup could be checked directly on the PC/Laptop without Patroller Interface
Unit connected.

Please check each screen before commencing Patroller Interface Unit upgrade.

2. Make sure that all required files indicated in are stored in the same directory.
2.1. All files are currently stored in Firmware_upgrade_files directory (This

directory will be defined by the end-user). An example is shown in Figure 1.
3. Start up SDFlash.exe. See Figure 8.

4. Go to File and select F2812SerialFlash.sdp. See Figure 11.

5. Select Project -> Settings...
5.1. See Figure 2.

F2812S5erialFlash.sdp - SDFlash

—’:IMSG: Interface version 1

i Programming Flash Loader /

JEdits the project settings UM /4

Figure 2: SDFlash Setup for firmware upgrade. Developer's side

6. Step 4 will open up the PSD_EMU_CONTROLLER_INFO window shown in
Figure 3.
6.1. In the Target tab:
6.1.1. Please make sure that the screen setup for the Target tab is as shown in

Figure 3.
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F2812SerialFlash.sdp - SDFlash

File View Project Buffer Device Window Help

D™ E &R 7w

PSD_EMU_CONTROLLER_INFO

Taget IErase I ngrammlngl WVerify I

Processor.  |GEMERIC

Driver:
|F2E1 RS 232Flash.di

Emulator: Emulator Address/|d:
|SEH\AL_FLASH COmM1

Board File:
|ocBrd028x dat

MSG: Interface wersion 1

(A

Processor Mame: Icpuj

[0]:4 I Cancel Help

4 [+ |5, Programming Flash { Loader /

Ready '_ W |

Figure 3: PSD_EMU_CONTROLLER_INFO Target Tag

7. Inthe PSD_EMU_CONTROLLER_INFO Erase tab shown in Figure 4
7.1. Please make sure that the screen setup for the Erase tab is as shown in Figure
4.

PSD_EMU_COMTROLLER_INFO

Target Erase F'n:ugrammingl"-.ferifyl

Algarithm File:

Timeout: IEI

IJzer Options 1: oot

[}

IJzer Ophiong 2

[N}

IJzer Ophiong 3:

500

IJzer Optiong 4:

k. I Cancel Help

Figure 4: PSD_EMU_CONTROLLER_INFO Erase Tab

8. In the PSD_EMU_CONTROLLER_INFO Programming tab shown in Figure 5.
8.1. Please make sure that the screen setup for the Programming tab is as shown in

Figure 5.
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8.2. Note that Flash Data File should be changed to the new firmware version to

be upgraded.

PSD_EMU_CONTROLLER_IMFO

Taget | Erase  Programming | Vesity |
Algorithm File:
F28125 eiial lash.out J

< Flash Data File:
Patroller2_Flash_v1.04_20070629.0ut

Timeout: |0

Usger Dplions 1: Iﬂ_
User Options 2: Iﬂ—
User Oplions 3: Iﬂ—
LUser Dptions 4: Iﬂ—

ok | cancel |\ Help
\

\
Please remember to change this file name to the
latest firmware version to be updated.

Figure 5: PSD_EMU_CONTROLLER_INFO Programming Tab

9. Inthe PSD_EMU_CONTROLLER_INFO Verify tab shown in Figure 6.
9.1. Please make sure that the screen setup for the Verify tab is as shown in

Figure 6.

PSD_EMU_CONTROLLER _INFO

Targetl Eraze ] Programming  Werify

Algorithm File:
[F281 25 eriafFlash. ou J

Timeout: |0

Uszer Options 1: lc'i
Uzer Options 2 ID—
|lzer Ophionz 3: ID—
Ilzer Options 4: ID—

(] | Cancel Help

Figure 6: PSD_EMU_CONTROLLER_INFO Verify Tab
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10. Please make sure that this step is completed, if any changes required between Step
5to 8.
10.1. Go to File -> Save Project
10.2. See Figure 7.

IFlash.sdp - SDFlash

N Yiew Project  Buffer Device Window Help

IMew Project Chrl+M
Open Project. .. Chr+O
Close Project

Save Project As..,

1 F28125erialFlash.sdp
2 Fza125erialFlash.sdp
3 Fza125erialFlash.sdp
4 F2&125erialFlash.sdp

Exit

ﬂMSG: Interface version 1

4 [ ¥ [%\ Programming Flash { Loader /

Save the active project l_ ’W l_ /A
Figure 7: File save Project after changes to SDFLASH Utility
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Section 5: Firmware Upgrade procedure after initial setup

Once everything is set up as described in the Section 4 above, it is necessary for the

end user to complete the following procedure:

1.

Connect the serial upgrade cable between the PC (COM1) and Patroller Interface
Unit.
Start up upgrade.bat, which copies files into their necessary locations and starts up

the SDFlash utility.

ENi=1}3

File ‘iew Project Euffer Dewice Window Help

D=E|E% R 2R

la Ix

4 [» [%, Programming Flash { Loader 7

Ready ,_W’_ 2l
Figure 8: SDFlash Utility

3. Open the F2812SerialFlash.sdp project file as follows.

3.1. If this is the first time SDFlash has been run on the Host PC:
3.1.1. Goto File. See Figure 9 and Figure 10.
3.1.2. Select Open Project ...
3.1.3. Go to the directory where F2812SerialFlash.sdp is located on the Host
PC (it will be in the folder in which the firmware upgrade files were

unpacked), and open the project.
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SDFlash

FN View Project  Buffer Device Window Help

Close Project
Save Project Chrl+5
Save Project As...

1 F28125erialFlash.sdp

Exit

A [ ¥ % Programming Flash  Loader /

Qpen an existing project I_W ’_ //J
Figure 9: End-User: Using SDFLASH for the first time

=]« @ e B

ﬂ File name: |F281 25enialFlash.sdp Open I
A
Files of type: IF'miect filess [*.5dp) ;I Cancel |
|
41 Programming Flash Loader /
Ready UM 4

Figure 10: End User opening F2812SerialFlash.sdp project for the first time

3.2. If SDFLash has been used on the host PC before, the File menu will contain

the entries shown in Figure 11.
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SDFlash =13

View Project Buffer Device ‘Window Help

Mew Project Chrl+h
Open Project... Chrl+0
Close Project

Save Project Chri+5
Save Project As..,

1 F26125etialFlash.sdp

Exit

4 [+ [\, Programming Flash  Loader /

]

Figure 11: Select F2812SerialFlash.sdp in SDFLASH Utility

3.3. Once F2812SerialFlash.sdp is selected, the white message screen at the
bottom of the window will show the following message: “MSG: Interface

version 1”.

4. Select Reseticon R as shown in F. igure 12.

rialFlash.sdp - SDFlash
File View Project Buffer Device ‘Window Help

DEE D& R 2K

*|[H5G Interface versiom 1

AlMsG: Tnloading driver

MSG: Reloading driver

HMSG: User must now get target to bootload state
MSG: Interface wersion 1

A4 [ ¥ [\, Programming Flash  Loader /

Ready [ um /4

Figure 12: RESET after opening. It is required to reset before performing the flash upgrade

4.1. The additional messages shown in Figure 12 will be shown in the message
board.

5. Select the flash icon as shown in Figure 13 below. The red arrow on the figure

shows the location of the flash icon on the screen. Alternatively, select Device->
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Flash from the main menu. Figure 14 shows the SDFlash window once this step is

completed.

[olF281 25erialFlash.sdp - SDFlash
Fle ¥iew Project Buffer Device Window Help

R 28

ﬂ SG: Interface version 1

Ty F ing Flash ( Loader

Control flash programring [ m[

Figure 13: Select Flash Icon

F 281 2SerialFlash.sdp - SDFlash

File ‘iew Project Buffer Device ‘Window Help

DEE D& R 28

¥ Erase v Program ¥ ety

|
Start I

ill Program C:~CCStudic w3 18HvProject="PAT2Sourcesafe Patroller? Flash-Debug“Patroller?_Flash.out loaded

< 1] | >
D Progmmming Flash % Loader
Ready TUIM él

Figure 14: Erase, Program and Verify
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6. At this point, the Patroller Interface Unit should be made ready to receive a
firmware upgrade. It is then necessary to press Start to Erase, Program and Verify

the DSP FLASH memory. See Figure 15 and Figure 16.

F281 2SerialFlash.sdp - SDFlash

File Wiews Project Buffer Device ‘Window Help

DEH D@ R 2N

v Erase v Program v ey

Connect...

[ ]
Start I Stop
ﬂMSG: Connecting to target
Ll I3 Programming Flash § Loader /
Ready MM /A

Figure 15: Connecting to target

281 2SerialFlash.sdp - SDFlash

File ‘Wiew Projeck Buffer Device ‘Window Help

DEE OB R|?N

v Erase V¥ Program v erify

x| 5. Connecting to target
AMS5: Connected to target

M55 Erase flash succeeded.
MS5: Program flash succesded.
MSG: Verify flash succeeded.

4 [ ¥ | Programming Flash ; Leader /

Ready I_WI_ A
Figure 16: Erase, Program, and Verify Flash succeeded

The firmware has been successfully upgraded after this stage. The user should press

the push button once to exit boot mode and return to normal flash operation.

29/11/2007 16



Note: Do not unselect Erase, Program or Verify options individually.

If SDFLASH is interrupted at any time during the operation, the end-user should
remove and re-connect the battery. In this situation, the boot-loader should still be
present, as this is not erased during the normal programming process, so to recover
the situation, it is necessary for the boot-loader to be started in the normal way by
holding down the power button, and resuming the flash upgrade from step 4 of this
section. In the event that the LED does not illuminate when the power button is

pressed, contact Palmer Environmental for support.
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