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Introduction 

This document has been written to facilitate the user in the use of PermaHOST Application 

Version 4.20 in conjunction with database version 4.20 

 

For  Authorisation Code (Page 156) 

 

For Automatic Database upgrade, please follow: 

•   Database Upgrade Procedure (With Registry Clean Up) (Page 25) 

For non-automated Database upgrade, please follow:  

•  Database->Update Database (Page 67) 

 

For Auto-Import Coronis XML File, please follow:  

•  Database->Auto-Import Coronis XML File (Page 74) 

For non-automated import of Coronis XML File, please follow: 

•  Database->Import Coronis XML File (Page 72) 

 

PermaHOST Installation Guide: 

- Install PermaHOST Application (Page 17) 

- Uninstall Previous PermaHOST Version (Page 23) 

 

Features Available For PermaHOST Version 4.20 with Database Version 4.20 (Page 26) 

 

 Setup PermaNet SMS Dialog Explained (Page 150) 

 

Quick Reference – Location Pane Logger Display Icon for Normal Pipe Sensitivity (Page 38) 

Quick Reference – Location Pane Logger Display Icon for Custom Pipe Sensitivity (Page 42) 

• Duplicated Serial Numbers Usage Explained. (Page 52) 

 

A Step by Step Guide is provided to the user: 

• STEP BY STEP GUIDE ON PERMAHOST APPLICATION (Page 54) 
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PermaHOST Installation Guide 

 

 

Figure 1: PermaHOST Application 

  

Figure 1 shows the installation file for PermaHOST Application.  

Note the previous version of PermaHOST should be uninstalled from the PC before 

carrying out the installation process. To uninstall previous Version, please follow the 

procedure Uninstall Previous PermaHOST Version. 

 

Install PermaHOST Application 

1. Double-click on the icon shown in Figure 1 that comes with your installation ZIP 

file. Figure 2 will be shown, followed by Figure 3. 

 

Figure 2:  Starting InstallShield Wizard... 

 

 

Figure 3:  InstallShield Wizard -> Choose Setup Language 

2. Select the Language you wish to use for the Application being installed. 



PermaHOST Application Manual for Version 4.20 with Database Version 4.20   MAN-064-0002-E 

       PermaHOST Installation Guide – Install PermaHOST Application 

 

HWM-Water Ltd (Palmer Environmental) – Your Gateway to the Latest Technology, Solutions 

and Services 

 

18 

2.1. Click . 

2.2. Figure 4, Figure 5 and Figure 6 will be shown. 

 

 

Figure 4: PermaHOST Application SETUP Screen (example) 

 

 

 

Figure 5: InstallShield Wizard -> Preparing Setup 
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Figure 6: InstallShield Wizard -> Welcome 

3. Once the screen in Figure 6 is shown. Click . 

3.1. Figure 7 Licence Agreement will be shown.  

3.2. Check the Radio Button:  

 

Figure 7: InstallShield Wizard -> License Agreement 
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4. Click . Customer Information screen will be shown (See Figure 8).  

4.1. Fill in the User Name and Company Name.  

 

Figure 8: InstallShield Wizard -> Customer Information 

 

5. Click . The “Choose Destination Location” Screen will be shown (See 

Figure 9). 

 

Figure 9: InstallShield Wizard -> Choose Destination Location 

6. Click . Figure 10 will be shown. 
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Figure 10: InstallShield Wizard -> Ready to Install the Program 

 

7. Click . Figure 11 will be shown.  

8. On completing the installation, Figure 12 will be shown.  

9. Click  

 

Figure 11: InstallShield Wizard -> Setup Status 
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Figure 12: InstallShield Wizard -> InstallShield Wizard Complete 

 

10. Notice that PermaHOST application and its shortcuts have been added to the 

Operating System: 

10.1. Desktop shortcut:  

10.2. Start up menu icon & path:  

 

11. To locate the installation file if the default installation path is chosen, please go to: 

11.1. C:\Program Files\ HWM-Water Ltd \PermaHOST 
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Uninstall Previous PermaHOST Version 

1. Double-click on the icon shown in Figure 1 that came with your installation ZIP 

file. Figure 2, Figure 4 and Figure 5 will be shown in turn.  

2. When Figure 5 process bar has been completed, Figure 13 will be shown. 

 

Figure 13: InstallShield-> Modify, repair, or remove the program 

 

3. Select the Radio Button  as shown in Figure 13. 

4. Click . Figure 14 will be shown.  

5. Click  to remove PermaHOST Application.  

5.1. Figure 11 will be shown (SETUP STATUS). 

 

Figure 14: Confirm File Deletion (Uninstall Previous Version of PermaHOST) 

 

6. When the uninstall process had been completed. Figure 15 will be shown.  

7. Click . 
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8. Notice that PermaHOST application and its shortcuts have been removed from the 

Operating System.  

 

Figure 15: Uninstall (Completed Screen) 

 



PermaHOST Application Manual for Version 4.20 with Database Version 4.20   MAN-064-0002-E 

  Database Upgrade Procedure (With Registry Clean Up) 

 

HWM-Water Ltd (Palmer Environmental) – Your Gateway to the Latest Technology, Solutions 

and Services 

 

25 

 Database Upgrade Procedure (With Registry Clean Up) 
 

NOTE: Database Upgrade Procedure instructions below only apply to 

PermaHOST Application V4.00 onwards. If you are not using Application from 

Version V4.00, please refer to previous MAN-064-0002-C for the old procedure 

to upgrade your database.  

 

The following Application Versions are supported for Automatic Database 

upgrade. Supported Application versions are V3.50, V3.70, V3.80, V3.81, V3.82, 

V3.90 and V4.00 onwards.  

 

Upon Installation of Application Version from V4.00 onwards, should a previous 

installation registry exist, the application will automatically commence the Database 

upgrade to work with the current Application version. The old registry will 

automatically be deleted after being copied to the new application registry.  

On completion of the automatic upgrade of the last opened database, the PermaHOST 

Application will automatically start with the new database and new copied registry.  

 

If there is no previous registry, hence no database to be upgraded automatically, the 

user has to select a valid database version to open with the designated version of 

PermaHOST Application.  

 

Location of 

Current Access 

Database on the 

Computer

 

Figure 16: Location of Current Access Database 

 

The current selected and opened database will be shown on the title bar, as shown in 

the example in Figure 16.  
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Features Available For PermaHOST Version 4.20 with Database Version 4.20 

 

Status Bar

Title Menu

Toolbar

Filter Summary Icon

L
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Graphical Pane

Summary Screen Icon

 

Figure 17: PermaHOST Application Screen 
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Figure 17 shows the PermaHOST Application screen.  

 

“Title Menu” contains the following main menu items: 

1. File 2. Edit 3. View 4. Settings 5. Database  6. Help  

• From V4.00 onwards, the “Title Menu” also includes “Database” option. 

 

The Application is split into 3 windows/panes.  

1. Location Pane 

2. Data Pane 

3. Graphical Pane 

 

The Toolbar ( ) provides shortcut that the user could use.  

• From Version 3.70, the toolbar also includes a filter summary icon:  (Note this icon is greyed out, when no filter is active) 

• From Version 3.80, the toolbar also includes a Summary Screen Icon:   

 

The Status Bar simply provides information to the end user. E.g. Modem Signal Strength. 
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Title menu 

 

Table 1: Title menu -> File Options 

(See Figure 18) 

1. File->New Access Database 

2. File->New Area/Regions 

3. File->Open Access Database 

4. File->Save As… 

5. File->Print Setup… 

6. File->Exit  

Figure 18: Title Menu->File  

 

Table 2: Title menu -> View Options 

(See Figure 19) 

7. View->Toolbar 

8. View->Status Bar 

(See Figure 19 & Figure 20) 

9. View->Filters 

9.1. Date Range 

9.2. PermaNet SMS Number 

(SIM/Serial) 

9.3. Leak Only 

9.4. No Leak Only 

9.5. Active Loggers Only 

9.6. Inactive Loggers Only 

9.7. Location Number 

 

Figure 19: Title Menu-> View 

 

 

Figure 20: Title Menu-> View-> Filters 
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Table 3: Title menu -> Settings Options 

(See Figure 21) 

10. Settings->Modem Settings->Port->COM x (where x ranges from 1 to 16) 

11. Settings->Modem Settings->Type->{modem type} 

12. Settings->Date Format (For this part, everything related to date is supposed to be in the 

selected format. Except in Logger Details and Modify loggers.). 

12.1. DD/MM/YY    

12.2. MM/DD/YY 

12.3. YYYY/MM/DD 

13. Settings->Logfiles 

13.1. New Log Files 

13.1.1. New PermaHOST Application Log File 

13.1.2. New PermaHOST Error Log File 

13.1.3. New Incoming SMS Log File 

13.1.4. New Outgoing SMS Log File 

13.1.5. New Activity Log File 

13.2. Clear Log Files 

13.2.1. Clear PermaHOST Application Log File 

13.2.2. Clear PermaHOST Error Log File 

13.2.3. Clear Incoming SMS Log File 

 

Figure 21: Title Menu->Settings 
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13.2.4. Clear Outgoing SMS Log File 

13.2.5. Clear Activity  

 

13.3. View Log Files FilePath  

13.3.1. Displays the full file path of the logfiles location as shown in Figure 61. 

13.3.2. Note the default log files if the user does not define them are located in: 

13.3.2.1. C:\Program Files\ HWM-Water Ltd \PermaHOST\Logfiles\IncomingSmsLog.log 

13.3.2.2. C:\Program Files\ HWM-Water Ltd \PermaHOST\Logfiles\OutgoingSmsLog.log 

13.3.2.3. C:\Program Files\ HWM-Water Ltd\PermaHOST\Logfiles\PermaHOSTAppLog.log 

13.3.2.4. C:\Program Files\ HWM-Water Ltd\PermaHOST\Logfiles\PermaHOSTErrorLog.log 

13.3.2.5. C:\Program Files\ HWM-Water Ltd\PermaHOST\Logfiles\testDBLogFilesDir\testDBActivityLog.log 

14. Settings -> Auto-Send SMS to retrieve PermaNET SMS Config 

14.1. When there is a next to this setting, if a PermaNet SMS reports a GNET message for the first time and the PermaNet SMS 

configuration is not available in the database, PermaHOST will auto-send a message to the PermaNET SMS to retrieve its configuration. 

This will only be done once to avoid SMS wastage.  

14.2. If the user chooses not to tick this option, the user could manually use PermaHOST to send a message to retrieve a particular 

PermaNET SMS as described in Data Pane-> PermaNet SMS ->Send SMS to get PermaNet SMS Configuration (Page 98).  

14.3. By default, the auto-send feature is “ON”. 
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Table 4: Title menu -> Database Options 

(See Figure 22) 

10. Database->Upgrade Database (Page 67) 

10.1. Used for database upgrade of previous PermaHOST Application Version database/s.  

10.2. Previous Application Version supported is V3.50, V3.70, V3.80, V3.81, V3.82 and 

V3.90.  

10.3. From V4.00 onwards, database upgrade will be supported.  

11. Database->Import Coronis XML File (Page 72) 

11.1. Used for importing Coronis XML File to populate the database with logger Level and 

Spread History.  

12. Database->Auto-Import Coronis XML File (Page 74) 

12.1. If�, the application will automatically extract Coronis XML file to populate the 

database with logger Level and Spread History.  

  

Figure 22: Title Menu->Database-

>Upgrade Database, Import/Auto-Import 

Coronis XML File 

 

 

13. Help->About PermaHOST… 

 

Figure 23: Title Menu->Help 

Most items in the PermaHOST application can be right-clicked to show a context menu applicable to the selected item.  Some of the menu items 

are described below. 
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 Unrecognised Messages 

1. Location Pane->Clear All Unrecognised Messages 

2. Location Pane->Clear Incoming SMS Log File 
 

3. Data Pane->Copy 

4. Data Pane->Remove  

 

 Received Messages 

1. Location Pane->Clear All Received Messages 

2. Location Pane->Clear Incoming Message Log File  

3. Data Pane->Copy 

4. Data Pane->Remove selected Message 

5. Data Pane->Clear All Incoming Messages  

 

 Sent Messages 

1. Location Pane->Clear All Sent Messages 

2. Location Pane->Clear Outgoing Message Log File 

3. Data Pane->Copy 

4. Data Pane->Clear Selected Sent Message 

5. Data Pane->Clear All Sent Messages 

 

 Failed Messages 

1. Location Pane->Clear All Failed Messages 

2. Location Pane->Clear Outgoing Message Log File 

3. Data Pane->Copy to Clipboard 

4. Data Pane->Send Selected Message Now 

5. Data Pane->Remove Selected Message  
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 ALARMS 

1. Location Pane->Export Alarms Histories 

2. Location Pane->Clear All Alarm Histories  

3. Data Pane->Export Alarm Histories 

4. Data Pane->Delete Selected Alarm History 

5. Data Pane->Print Alarm Histories 

6. Data Pane->Print Preview 
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 PermaNet SMS 

 

(See Figure 24) 

1. Location Pane->Add PermaNet SMS Config 

2. Location Pane->Export PermaNet SMS Configurations To CSV 

 

Figure 24: Location Pane PermaNet SMS Context Menu (Right-Click to access) 

(See Figure 25) 

3. Data Pane->Delete Selected PermaNet SMS Configuration   

4. Data Pane->Add New PermaNet SMS Configuration 

5. Data Pane->Edit PermaNet SMS Configuration 

6. Data Pane->Send SMS to get PermaNet SMS Configuration 

6.1. This option allows user to use PermaHOST Application to 

send a “GET CONFIG” message to the PermaNet SMS.  

6.1.1. On the PermaNet SMS next data report day, 

PermaHOST should receive the configuration response 

from the PermaNet SMS and automatically update the 

database with this configuration.  

6.2. Note to use this option, user must at least enter the PermaNet 

SMS Telephone Number in “Setup PermaNet SMS” Dialog 

box.  

 

Figure 25: Data Pane PermaNet SMS Context Menu (Right-Click to access) 
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7. Data Pane->For Trained Engineer Use  

7.1. Data Pane->For Trained Engineer Use->PermaNet SMS 

Information 

7.2. Data Pane->For Trained Engineer Use->PermaNet Alarm 

Specification  

 

 

 For database (file with .mdb extension)  

1. Location Pane->Add Areas/Regions 

2. Location Pane->Close Access Database 

3. Location Pane->Host PC Telephone Number 

4. Location Pane->View Loggers in Leak State 
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 For Area/Region 

(See Figure 26) 

1. Location Pane->Add Logger 

1.1. For PermaHOST Application version prior to version 3.8x, to link a 

PermaNet SMS to a Permalog+, user must enter the PermaNET SMS 

Telephone number.  

1.2. From PermaHOST Application version 3.8x onwards, PermaHOST will 

automatically link a logger to the PermaNET SMS that send it GNET 

messages. PermaNET SMS Serial number is also automatically linked for the 

end user.  

2. Location Pane->Export Area/Region Loggers Data Report to CSV 

3. Location Pane->Export Area/Region Loggers Details to CSV 

4. Location Pane->Export Active Loggers Details & Data Report to PermaLog CSV 

5. Location Pane->Export Active Loggers Telephone Numbers to CSV 

6. Location Pane->Rename Area/Region 

7. Location Pane->Remove Area/Region 

8. Location Pane->Send Text Message (To be removed)  

8.1. This option will be removed on the final release. Currently it is in the 

application because it is still in development.  

9. Location Pane->INACTIVATE All Loggers in Selected Area/Region 

10. Location Pane-> Selective Activation/Deactivation of logger in Area/Region 

11. Change Pipe Sensitivity of all Loggers in Selected Area/Region 

12.  

 

Figure 26: Location Pane Area/Region Context Menu (Right-Click to access) 
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 For Permalog+ Loggers 

 

(See Figure 27) 

1. Location Pane->View Logger Details 

2. Location Pane->Modify Logger Details  

2.1. Note: To link a PermaNet SMS to a Permalog+, the user must enter the 

PermaNet SMS Telephone number.  

3. Location Pane->Export Logger Data Report to CSV 

4. Location Pane->Setup PermaNet SMS 

5. Location Pane->Move Logger to Another Area/Region 

6. Location Pane->Make Logger Active 

6.1. NOTE: At any one time for any duplicated serial number, only one of the 

duplicated numbers is allowed to be ACTIVE.  

7. Location Pane->Delete Logger 

8. Location Pane->Make Logger Inactive 

8.1. The user is allowed to make all duplicated serial numbers INACTIVE. Note 

that if this is the case, on receiving a GNET message with that particular 

serial, a new duplicated serial number will be created and made ACTIVE.  

9. Manually Add/Change Level & Spread History 

 

Figure 27: Location Pane Permalog+ Logger Context Menu (Right-Click to access) 

 

10. Data Pane->Print Data Report 

11. Data Pane->Print Preview 

12. Data Pane->Delete Selected Data Report 

13. Graphical Pane->Print Graph (Slow at the moment as printing in BMP.) 

14. Graphical Pane->Print Preview  
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Quick Reference – Location Pane Logger Display Icon for 

Normal Pipe Sensitivity 

 

 Leak Display Icon in Location Pane (For Active Permalog+ Logger/s 

with No Alarm Condition/s in Latest Data & Normal Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 28 is displayed in the Location 

Pane only if the following conditions are all true:  

1. The latest logger Data Report has a leak.  

2. ALARM/s has not been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is default/normal.  

 

 Figure 28: Leak Display in Location Pane (For Active Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Normal Pipe Sensitivity) 

 

 

 

No Leak Display Icon in Location Pane (For Active Permalog+ 

Logger/s with No Alarm Condition/s in Latest Data & Normal Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 29 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has not been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is default/normal.  

 

 Figure 29: No Leak Display in Location Pane (For Active Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Normal Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Inactive Permalog+ Logger/s 

with No Alarm Condition/s in Latest Data & Normal Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 30 is displayed in the Location 

Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak 

2. ALARM/s has not been triggered. 

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is default/normal.  

 

 Figure 30: Leak Display in Location Pane (For Inactive Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Normal Pipe Sensitivity) 

 

 

No Leak Display Icon in Location Pane (For Inactive Permalog+ 

Logger/s with No Alarm Condition/s in Latest Data & Normal Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 31 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has not been triggered.  

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is default/normal.  

 

 Figure 31: No Leak Display in Location Pane (For Inactive Permalog+ Logger/s with No 

Alarm Condition/s in Latest Data & Normal Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Active Permalog+ Logger/s 

with ALARM Condition/s in Latest Data & Normal Pipe Sensitivity) 

A Leak Display Icon, with ALARM symbol, as the one shown in  Figure 32 is 

displayed in the Location Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak. 

2. ALARM/s has been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is default/normal. 

 

 Figure 32: Leak Display in Location Pane (For Active Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Normal Pipe Sensitivity) 

 

 

 

No Leak Display Icon in Location Pane (For Active Permalog+ 

Logger/s with ALARM Condition/s in Latest Data & Normal Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 33 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is default/normal. 

 

 Figure 33: No Leak Display in Location Pane (For Active Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Normal Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Inactive Permalog+ Logger/s 

with ALARM Condition/s in Latest Data & Normal Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 34 is displayed in the Location 

Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak. 

2. ALARM/s has been triggered. 

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is default/normal. 

 

 Figure 34: Leak Display in Location Pane (For Inactive Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Normal Pipe Sensitivity) 

 

 

No Leak Display Icon in Location Pane (For Inactive Permalog+ 

Logger/s with ALARM Condition/s in Latest Data & Normal Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 35 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report.  

2. ALARM/s has been triggered.  

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is default/normal. 

 

 Figure 35: No Leak Display in Location Pane (For Inactive Permalog+ Logger/s with 

ALARM Condition/s in Latest Data & Normal Pipe Sensitivity) 
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Quick Reference – Location Pane Logger Display Icon for 

Custom Pipe Sensitivity 

 

 Leak Display Icon in Location Pane (For Active Permalog+ Logger/s 

with No Alarm Condition/s in Latest Data & Custom Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 36 is displayed in the Location 

Pane only if the following conditions are all true:  

1. The latest logger Data Report has a leak.  

2. ALARM/s has not been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom.  

 

 Figure 36: Leak Display in Location Pane (For Active Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Custom Pipe Sensitivity) 

 

 

 

No Leak Display Icon in Location Pane (For Active Permalog+ 

Logger/s with No Alarm Condition/s in Latest Data & Custom Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 37 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has not been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom.  

 

 Figure 37: No Leak Display in Location Pane (For Active Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Custom Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Inactive Permalog+ Logger/s 

with No Alarm Condition/s in Latest Data & Custom Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 38 is displayed in the Location 

Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak 

2. ALARM/s has not been triggered. 

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom. 

 

 Figure 38: Leak Display in Location Pane (For Inactive Permalog+ Logger/s with No Alarm 

Condition/s in Latest Data & Custom Pipe Sensitivity) 

 

 

No Leak Display Icon in Location Pane (For Inactive Permalog+ 

Logger/s with No Alarm Condition/s in Latest Data & Custom Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 39 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has not been triggered.  

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom.  

 

 Figure 39: No Leak Display in Location Pane (For Inactive Permalog+ Logger/s with No 

Alarm Condition/s in Latest Data & Custom Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Active Permalog+ Logger/s 

with ALARM Condition/s in Latest Data & Custom Pipe Sensitivity) 

A Leak Display Icon, with ALARM symbol, as the one shown in  Figure 40 is 

displayed in the Location Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak. 

2. ALARM/s has been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom. 

 

 Figure 40: Leak Display in Location Pane (For Active Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Custom Pipe Sensitivity) 

 

 

No Leak Display Icon in Location Pane (For Active Permalog+ 

Logger/s with ALARM Condition/s in Latest Data & Custom Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 41 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report. 

2. ALARM/s has been triggered.  

3. The logger is ACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom. 

 

 Figure 41: No Leak Display in Location Pane (For Active Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Custom Pipe Sensitivity) 
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 Leak Display Icon in Location Pane (For Inactive Permalog+ Logger/s 

with ALARM Condition/s in Latest Data & Custom Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 42 is displayed in the Location 

Pane only if the following conditions are all true: 

1. The latest logger Data Report has a leak. 

2. ALARM/s has been triggered. 

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom. 

 

 Figure 42: Leak Display in Location Pane (For Inactive Permalog+ Logger/s with ALARM 

Condition/s in Latest Data & Custom Pipe Sensitivity) 

 

No Leak Display Icon in Location Pane (For Inactive Permalog+ 

Logger/s with ALARM Condition/s in Latest Data & Custom Pipe 

Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 43 is displayed in the 

Location Pane only if the following conditions are all true: 

1. There is no leak in the latest Data Report.  

2. ALARM/s has been triggered.  

3. The logger is INACTIVE. 

4. The Pipe Sensitivity is plastic/sensitive/custom. 

 

 Figure 43: No Leak Display in Location Pane (For Inactive Permalog+ Logger/s with 

ALARM Condition/s in Latest Data & Custom Pipe Sensitivity) 
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Quick Reference – Data Pane Logger Leak Status Display 

Icons 

 

Leak Display Icon in Data Pane (Normal Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 44 is displayed in the Data Pane 

when there is a leak on a particular Data Report and the Pipe Sensitivity is 

default/normal. 

 

 Figure 44: Leak Display Icon in Data Pane (Normal Pipe Sensitivity) 

 

 No Leak Display Icon in Data Pane (Normal Pipe Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 45 is displayed in the Data 

Pane when there is no leak in a particular Data Report and the Pipe Sensitivity is 

default/normal. 

 

 Figure 45: No Leak Display Icon in Data Pane (Normal Pipe Sensitivity) 

 

Leak Display Icon in Data Pane (Custom Pipe Sensitivity) 

A Leak Display Icon as the one shown in  Figure 46 is displayed in the Data Pane 

when there is a leak on a particular Data Report and the Pipe Sensitivity is 

plastic/sensitive/custom. 

 

 Figure 46: Leak Display Icon in Data Pane (Custom Pipe Sensitivity) 

 

 No Leak Display Icon in Data Pane (Custom Pipe Sensitivity) 

A No Leak Display Icon as the one shown in  Figure 47 is displayed in the Data 

Pane when there is no leak in a particular Data Report and the Pipe Sensitivity is 

plastic/sensitive/custom. 

 

 Figure 47: No Leak Display Icon in Data Pane (Custom Pipe Sensitivity) 
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 ALARM Reports Data Pane Display 

 

Figure 48: ALARM Reports Data Pane Display 

Figure 48 shows the ALARM Reports Data Pane Display.  

Table 5: Data Pane for Alarm Reports 

EventID Identification number of the alarm stored in the database table.  

PermaLog Serial (?) PermaLog Logger Serial number (with its alphabet identification). 

ECU No. This is usually the last 4 digits of the PermaNet Serial. 

PermaNet Serial PermaNet SMS Serial number. 

PermaNet SMS Tel PermaNet SMS Telephone Number. 

Date/Time Date and time the Alarm message was received by PermaHOST. 

Scheduled/Unscheduled Indicates if the received GNET alarm message is a scheduled or unscheduled message. 

1. Scheduled means the PermaNet SMS was supposed to Data Report on the particular date and time the GNET 

message with Alarm contents was received by PermaHOST. 

2. Unscheduled means the PermaNet SMS was not supposed to Data Report on the particular date and time the 

GNET message with Alarm contents was received by PermaHOST. 

PermaNet SMS Alarm Type Indicates the type of PermaNet SMS Alarm triggered. Possible types are: 

1. Low GSM Signal Strength xxx% 

2. Low Battery 
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PermaLog+ Alarm Type Indicates the type of PermaLog+ Alarm triggered. Possible types are: 

1. Low Battery 

2. Low RF Signal Strength xxx% 

3. Leak to No Leak  

4. No Leak to Leak  
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 PermaNet SMS Data Pane Display 

 

Figure 49: PermaNet SMS Data Pane Display 

Figure 49 shows the PermaNet SMS Data Pane Display.  

 
Table 6: Data Pane for PermaNET SMS 

PermaNet Serial PermaNet SMS Serial number. 

ECU No. 1. This value is only filled in when a SMS Configuration Message Response has been received by the application.  

2. This value is usually the last 4 digits of the PermaNet Serial.  

PermaNet SMS Tel PermaNet SMS Telephone Number 

1. This value could be specified by the user or it could be added automatically when a SMS Configuration Message 

Response from a PermaNet SMS has been received by the PermaHOST application.  

2. Note the minimum requirements for the user to specify a PermaNet SMS Configuration is for the user to enter the 

PermaNet SMS Telephone Number.  

Host PC Tel Refers to the Host PC Telephone Number (In PermaHOST Application, the modem linked to the computer running 

PermaHOST is the Host PC SIM Number.) 

This value could be specified by the user or it could be added automatically when a PermaNet SMS Configuration 

Message Response has been received by the application.  

Num2 Second Mobile Number.  
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This value could be specified by the user or it could be added automatically when a PermaNet SMS Configuration 

Message Response has been received by the application. 

Patrol Days 1. The Days the PermaNet SMS will wake up to wait for Permalog+ Patrol Data.  

2. SMTWTFS refers to Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday.  

2.1. Any days that the device is not patrolling will be shown as a dash. E.g. –  

3. This value could be specified by the user or it could be added automatically when a PermaNet SMS 

Configuration Message Response has been received by the application.  

Patrol Start Time 1. The time the PermaNet SMS will wake up to receive patrol data from the Permalog+ Loggers out in the field.  

2. This value could be specified by the user or it could be added automatically when a PermaNet SMS 

Configuration Message Response has been received by the application.  

Patrol Duration 

(seconds) 

1. The duration the PermaNet SMS will stay awake to wait for Permalog+ Patrol Data. 

2. This value could be specified by the user or it could be added automatically when a PermaNet SMS 

Configuration Message Response has been received by the application.  

Data Report Days 1. The Days the PermaNet SMS will wake up to send the data report it has stored to the Host PC Telephone 

Number.  

2. SMTWTFS refers to Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday.  

2.1. Any days that the device is not reporting will be shown as a dash. E.g. – 

3. This value could be specified by the user or it could be added automatically when a PermaNet SMS 

Configuration Message Response has been received by the application.  

Data Report Time 1. The time the PermaNet SMS will wake up to send data back to the Host PC Telephone Number.  
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2. This value could be specified by the user or it could be added automatically when a PermaNet SMS 

Configuration Message Response has been received by the application.  

Pending Configuration? Indicate if there is a Pending Configuration for the PermaNet SMS.  
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Duplicated Serial Numbers Usage Explained.  

Prior to Version 3.50 with database Version 3.3, PermaHOST Application allows the 

user to enter only one unique Serial Number in each Area/Region.  

If the same Serial Number existed in other Area/Region within the same database, the 

GNET message update will only update one of the serial numbers.  

 

For PermaHOST Version 3.50 to Version 3.8x, duplicated Serial numbers can exist in 

the same Area/Region or difference Area/Region for up to 26 times. This is because at 

any one time, only one of the duplicated Numbers could be ACTIVE. All others will 

be shown as INACTIVE. When a GNET message arrives, it will automatically be 

updated into the ACTIVE Serial number. For these versions, the number of 

Area/Region permitted per database is restricted to ten areas/regions 

 

From PermaHOST Version 3.90 onwards, a logger could be duplicated up to a 

maximum of 475254 times, from (a) to (zzzz). And there is no restriction on the 

number of Area/Region in the database.  

 

Scenario 1: All duplicated Serial Logger INACTIVE when GNET message 

for the logger arrives 

Note: If the serial number is duplicated, but all duplicated numbers are set to 

INACTIVE state, when a GNET message arrives with the particular duplicated serial 

number, a new duplicated serial number will be formed in Area/Region 

“PermaHOST”. This new duplicated serial number will be the ACTIVE logger.  

 

Scenario 2: Making an INACTIVE logger ACTIVE while another Logger 

with the same serial is ACTIVE 

The user could reactivate an INACTIVE logger at any time. When an INACTIVE 

logger is made ACTIVE, the previously ACTIVE logger of the same serial will 

become INACTIVE.  
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Scenario 3: Moving logger to another Area/Region without moving it’s 

Data Reports 

If the user chooses to move the logger to another Area/Region, without moving it data 

reports, the logger data reports will remain with the existing logger.  

Note: The existing logger will be deactivated.  

The newly created logger in the selected Area/Region to move to, will contain all 

status information (with the exception of deployed date) of the logger. The newly 

created logger will contain no previous data reports.  

 

Scenario 4: Moving Logger to another Area/Region with it’s Data 

Reports 

If the user chooses to move the logger to another Area/Region with its data reports: 

1. The moved logger will remain in whatever state it was in previously.  

1.1. If the previous state is ACTIVE, logger will remain ACTIVE 

1.2. If the previous state is INACTIVE, logger will remain INACTIVE.  

2. The moved logger will contain: 

2.1. All of its status information  

2.2. All of its data reports 
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STEP BY STEP GUIDE ON PERMAHOST APPLICATION 

Starting the Application  

1. Start PermaHOST Application.  

1.1. If Automatic database upgrade is to be performed, this will be performed 

automatically and will require no input from the end user.  

1.2. The Modem initialisation screen will popup as shown in Figure 50. 

2. On successfully initialising the modem, a message box that timeout will popup as 

shown in Figure 51. 

3. Either wait or click “OK” to close the popup message box. 

4. The PermaHOST Summary Screen Dialog shall automatically popup next. An 

example of this dialog box is shown in Figure 113.  

5. To know how to navigate through the PermaHOST Summary Screen, please refer 

to  PermaHOST Summary Screen Dialog Box (Page 130)  

 

Figure 50: Modem Initialisation Dialog 

 

 

 

Figure 51: Modem Initialised Successfully Popup Message Box with Timeout 
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File->New Access Database (Mouse click option) 

1. Use the mouse to select File->New Access Database in the Title Menu. 

2. The Save As dialog box similar to Figure 52 will pop up,  

2.1. Select the appropriate location to save the new Database. 

2.2. Enter a file name or select an existing database to overwrite. 

2.3. Click Save or Cancel  

2.3.1. Save will create the new database in the location specified.  

2.3.2. Cancel will exit the dialog box without creating the new database.  

 

Figure 52: File->New Access Database 

 

Figure 53: File->Open Access Database 

  

 

File->New Access Database (Keyboard option-> Ctrl+N)  

1. Using the keyboard, press down on Ctrl and N. 

2. The Save As dialog box similar to Figure 52 will pop up,  

2.1. Select the appropriate location to save the new Database. 

2.2. Enter a new file name or select an existing database to overwrite. 

2.3. Click Save or Cancel  

2.3.1. Save will create the new database in the location specified.  

2.3.2. Cancel will exit the dialog box without creating the new database.  

 

File->Open Access Database (Mouse click option) 

1. Use mouse to select File->Open Access Database in the Title Menu. 

2. The Open dialog box similar Figure 53 to will pop up,  

2.1. Select an existing database to open with the mouse.  

2.2. Click Open or Cancel  

2.2.1. Open will add the selected database to be opened to the Location Pane.  

2.2.2. Cancel will exit the dialog box without opening the selected database.  
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File->Open Access Database (Keyboard option-> Ctrl+O) 

1. Using the keyboard, press down on Ctrl and O. 

2. The Open dialog box similar to Figure 53 will pop up,  

2.1. Select an existing database to open with the mouse.  

2.2. Click Open or Cancel  

2.2.1. Open will add the selected database to be opened to the Location Pane.  

2.2.2. Cancel will exit the dialog box without opening the selected database.  

 

File->Save As…  

1. Use mouse to select File->Save As…in the Title Menu. 

2. A dialog box, similar to the one shown in Figure 52 will be shown.  

3. Enter a new file name or select an existing database to overwrite.  

3.1. This option will save the entire content of the currently opened active 

database to the new file.  

 

File->Print Setup…  

1. Use mouse to select File->Print Setup…in the Title Menu. 

2. The Print Setup dialog box should pop up.  

3. Select the appropriate printer and settings required.  

4. Click OK. The print setup will now remember the settings and printer to use until 

the PermaHOST application is restarted.  

 

File->Exit…  

1. Use the mouse to select File->Exit in the Title Menu.  

2. A message prompt will pop up with “This will close the PermaHOST application. 

Are you sure?” 

3. On clicking: 

3.1. No - Nothing will happen 

3.2. Yes - The whole application will exit 
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View->Toolbar 

Please refer to Figure 17 for clarification of where the Toolbar is on the Application 

screen. 

If the View->Toolbar has a � next to it, the Application screen will be similar to 

Figure 54.  

 

Figure 54: View->Toolbar (SELECTED) & View->Status Bar (SELECTED) 

 

If the View->Toolbar does not have a � next to it, the Application screen will be 

similar to Figure 55 

 

Figure 55: View->Toolbar (NOT SELECTED) 

 

View->Status Bar 

Please refer to Figure 17 for clarification of where the Status Bar is on the 

Application screen. 

If the View->Status Bar has a � next to it, the Application screen will be similar to 

Figure 54. 

 

If the View->Status Bar does not have a � next to it, the Application screen will be 

similar to Figure 56. 
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Figure 56: View->Status Bar (NOT SELECTED) 

 

View->Filters 

Filters have been implemented from PermaHOST Application Version 3.60 onwards. 

There are 7 filtering options available, and the user has the option to either use one 

filter or a combination of filters.  

Although there are 7 filters available, only 5 could be activated at the same time. 

Reasons: 

• Leak and No Leak filters cannot be turned on at the same time. Selecting one 

will automatically deselect the other.  

• Active and Inactive filters cannot be turned on at the same time. Selecting one 

will automatically deselect the other.  

When no filter is activated, the Toolbar icon will be shown as:  

If one or more filters are activated, the Toolbar icon will be shown as:  

View->Filters->Date Range 

This option allows the user to set the filter date range. Figure 57 shows an example of 

the dialog box when the user chooses to filter by Date Range.  

The date filter will be applied to: 

1. Unrecognised Messages  

2. Received Messages 

3. Sent Messages 

4. Failed Messages 

5. ALARMS Reports 

6. Loggers Data Reports 

 

 

Figure 57: View->Filters->Date Range 
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Figure 58: View->Filters->Date Range (Date-Time Picker) 

 

When the filter dialog first pops up, End Filter Date is not selectable, until the user 

selects a date from the date-time picker as shown in Figure 58. Once the date-time 

picker has been selected, the End Filter Date will be enabled. The user will be allowed 

to select the same date or a later date than the Start Filter Date. The user will not be 

allowed to select an End Filter Date that occurs before the Start Filter Date. To select 

an earlier End Filter Date, please reselect an earlier Start Filter Date. 

 

On “OK”, the date filter range will be applied and the screen will refresh 

automatically. The date filter will be continuously applied, until the user disables 

Filtering by date.  

When the date filter is on: View->Filters->Date Range will have a � next to it.  

When the filter is off: View->Filters->Date Range will not have a � next to it. 

 

To deselect the date filter when it is activated, simply select View->Filters->Date 

Range, or use the toolbar icon  to deselect individual filter/s in the Filters 

Information Dialog Box, detailed in  View Filters Information Dialog Box. 

View->Filters->PermaNet SMS Number (SIM/Serial) 

This option allows the user to filter by PermaNet SMS Number. Figure 59 shows an 

example of the dialog box when the user chooses to filter by PermaNet SMS Number. 

Selecting either Filter by PermaNet SMS SIM Number Option or Filter by PermaNet 

SMS Serial Number Option will enable the respective combo boxes list, which will 

allow the user to select PermaNet SMS SIM or Serial available in the database to 

perform filtering by PermaNet SMS Number.  
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To deselect the PermaNet SMS Number filter when it is activated, simply select 

View->Filters->PermaNet SMS Number (SIM/Serial), or use the toolbar icon  to 

deselect individual filter/s in the Filters Information Dialog Box, detailed in  View 

Filters Information Dialog Box. 

 

 

Figure 59: View->Filters->PermaNet SMS Number (SIM/Serial) 

 

View->Filters->Leak Only 

This option allows the user to set the filter by Leak Only in the latest Data Report, 

when selected the screen will refresh automatically. The “Leak Only” filter will be 

continuously applied, until the user disables Filtering by Leak Only. 

When the Leak Only filter is on: View->Filters->Leak Only will have a � next to it.  

When the filter is off: View->Filters->Leak Only will not have a � next to it. 

To deselect the Leak Only filter when it is activated, simply select View->Filters-

>Leak Only, or use the toolbar icon  to deselect individual filter/s in the Filters 

Information Dialog Box, detailed in  View Filters Information Dialog Box. 

Alternatively, if the user wishes to filter by No Leak Only, selecting No Leak Only 

will automatically deselect Leak Only filter.  
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View->Filters->No Leak Only 

This option allows the user to set the filter by No Leak Only in the latest Data Report, 

when selected the screen will refresh automatically. The “No Leak Only” filter will be 

continuously applied, until the user disables Filtering by No Leak Only. 

When the No Leak Only filter is on: View->Filters->No Leak Only will have a � next 

to it.  

When the filter is off: View->Filters->No Leak Only will not have a � next to it. 

To deselect the No Leak Only filter when it is activated, simply select View->Filters-

>No Leak Only, or use the toolbar icon  to deselect individual filter/s in the Filters 

Information Dialog Box, detailed in  View Filters Information Dialog Box. 

Alternatively, if the user wishes to filter by Leak Only, selecting Leak Only will 

automatically deselect No Leak Only filter.  

View->Filters->Active Loggers Only 

This option allows the user to set the filter by Active Loggers Only, when selected the 

screen will refresh automatically. The “Active Loggers Only” filter will be 

continuously applied, until the user disables Filtering by Active Loggers Only. 

When the Active Loggers Only filter is on: View->Filters->Active Loggers Only will 

have a � next to it.  

When the filter is off: View->Filters->Active Loggers Only will not have a � next to 

it. 

To deselect the Active Loggers Only filter when it is activated, simply select View-

>Filters->Active Loggers Only, or use the toolbar icon  to deselect individual 

filter/s in the Filters Information Dialog Box, detailed in  View Filters Information 

Dialog Box. 

Alternatively, if the user wishes to filter by Inactive Loggers Only, selecting Inactive 

Loggers Only filter will automatically deselect Active Loggers Only filter.  

View->Filters->Inactive Loggers Only 

This option allows the user to set the filter by Inactive Loggers Only. On select the 

screen will refresh automatically. The “Inactive Loggers Only” filter will be 

continuously applied, until the user disables Filtering by Inactive Loggers Only. 
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When the No Leak Only filter is on: View->Filters->No Leak Only will have a � next 

to it.  

When the filter is off: View->Filters->Inactive Loggers Only will not have a � next to 

it. 

To deselect the Inactive Loggers Only filter when it is activated, simply select View-

>Filters->Inactive Loggers Only, or use the toolbar icon  to deselect individual 

filter/s in the Filters Information Dialog Box, detailed in  View Filters Information 

Dialog Box. 

 

Alternatively, if the user wishes to filter by Active Loggers Only, selecting Active 

Loggers Only will automatically deselect Inactive Loggers Only filter.  

View->Filters->Location Number 

This option allows the user to filter by Location Number. Figure 60 shows an 

example of the dialog box when the user chooses to filter by Location Number.  

 

Figure 60: View->Filters->Location Number 

If any Location Number could be found it in the database, it will be automatically 

included in the list.  

When “OK” is clicked the Filter by Location Number will be applied and the screen 

will refresh automatically. The filter will be continuously applied until the user 

disables Filtering by Location Number.   

When the Location Number filter is on: View->Filters->Location Number will have a 

� next to it.  

When the filter is off: View->Filters->Location Number will not have a � next to it. 

To deselect the Location Number filter when it is activated, simply select View-

>Filters->Location Number, or use the toolbar icon  to deselect individual filter/s in 

the Filters Information Dialog Box, detailed in  View Filters Information Dialog 

Box. 
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Settings->Modem Settings->Port 

In Settings->Modem Settings->Port, if the modem is connected, the current port the modem is using will have a � next to it.  

Note: The application will always remember the last port it was connected to, the last time the application was ACTIVE. However, a � will only 

appear if the modem is ACTIVE. 

 

Settings->Modem Settings->Type 

In Settings->Modem Settings->Type, if the modem is connected, the current modem will have a � next to it.  

Note: The application will always remember the last modem it was using, the last time the application was ACTIVE. However, a � will only 

appear if the modem is ACTIVE. 

 

Settings->Date Format 

There are three available date format: 

1. DD/MM/YY 2. MM/DD/YY 3. YYYY/MM/DD 

The application will always remember the last date format selected.   

The selected date format will have a � next to it. 

 

Settings->Logfiles 

There are six available log files types. Note from Application Version 4.20 onwards, Log files locations are no longer stored as database objects. 

From Version 4.20 onwards, logfiles locations are registry objects.  

1. PermaHOST Application Log File 
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1.1. Default log file location if not defined: C:\Program Files\HWM-Water\PermaHOST\Logfiles\PermaHOSTAppLog.log 

2. PermaHOST Error Log File 

2.1. Default log file location if not defined: C:\Program Files\HWM-Water\PermaHOST\Logfiles\PermaHOSTErrorLog.log 

3. Incoming SMS Log File 

3.1. Default log file location if not defined: C:\Program Files\HWM-Water\PermaHOST\Logfiles\IncomingSmsLog.log 

4. Outgoing SMS Log File 

4.1. Default log file location if not defined: C:\Program Files\HWM-Water\PermaHOST\Logfiles\OutgoingSmsLog.log 

5. Activity Log File 

5.1. Default log file location if not defined: C:\Program Files\HWM-Water\PermaHOST\Logfiles\ActivityLog.log 

6. SMS LOG FILE 

6.1. Default log file location (Cannot be redefined or deleted via PermaHOST): C:\ SMSLog.txt 

Settings->Logfiles->New Log Files 

The end user could create the following new log files under this menu option. The directory these log files are created in is entirely up to the 

user. Once created, the database will remember where to log the required information into the various log files:  

1. New PermaHOST Application Log File 

2. New PermaHOST Error Log File 

3. New Incoming SMS Log File 

4. New Outgoing SMS Log File 

5. New Activity Log File 
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Settings->Logfiles->Clear Log Files 

The end user could clear the following log files under this menu option.  

1. Clear PermaHOST Application Log File 

2. Clear PermaHOST Error Log File 

3. Clear Incoming SMS Log File 

4. Clear Outgoing SMS Log File 

5. Clear Activity Log File 

Settings->Logfiles->View Log Files FilePath 

1. The end user could view this dialog box to know the current location of the individual log files in the operating system for the opened 

Database. See Figure 61. 

 

Figure 61: Setting->LogFiles->View Log Files FilePath 
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Settings->Auto-Send SMS to Retrieve PermaNet SMS Config 

By default, this option is enabled. The user could disable this option if they uncheck this in the menu option.  

When enabled: 

• If a GNET message arrives and the PermaNet SMS Configuration is not available in the existing opened database a configuration request 

SMS will automatically be sent once only.  

• If the same PermaNet SMS number comes in again, a request for configuration will not be automatically sent again. 
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 Database->Update Database 

Database->Update Database allows user to upgrade database/s of the following 

application version only: V3.50, V3.70, V3.80, V3.81, V3.82 and V3.90. For 

Application version from V4.00 onwards, database/s upgrade will be supported. 

 

Figure 62 shows the “PermaHOST Application: Microsoft Access Database Upgrade” 

Dialog. Database to be upgraded needs to be chosen before other buttons will become 

visible.  

 
Figure 62: Database->Upgrade Database (Default Dialog) 

Procedure to Upgrade a Database Using Title Menu Option 

1. Click on the  button  

1.1. When a Database of an upgradeable version is selected: 

1.1.1. will display the previous 

application version.  

E.g.  

1.1.2.  will display the full pathname of the 

database to be upgraded.  

E.g.  
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1.2. The button 

will become invisible. See Figure 63. 

1.3. The button 

will become visible. See Figure 63.  

 
Figure 63: Database->Upgrade Database (Select New Database Name) 

 

2. Click on the   button  

2.1. Follow Procedure to Follow if PermaHOST Installation Directory Not Found if you get a 

similar message to the one shown in Figure 66.  

2.2. Select a new database name or overwrite an existing database.   

 

2.3. Once a new database name has been selected, the 

 button will 

become invisible.  

2.4. The  button will become visible.  

3. Click on the  button to start the 

database upgrades process.  
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3.1. On successful upgrade, the pop up message, an example of which shown in 

Figure 64, will be shown for 5 seconds. Figure 65 shows the database upgrade 

progress.  

3.2. After successfully upgrading a database. The user has the option to Upgrade 

another database by clicking  

3.2.1. If the user clicks , the dialog 

will return to the default dialog state, as shown in Figure 62.  

3.2.2. If there is no more database to upgrade. Click . 

 

Figure 64: Database->Upgrade Database (Successful Database Upgraded Pop up message 

example) 

 

 

Figure 65: Database->Upgrade Database (Successfully Updated)
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Procedure to Follow if PermaHOST Installation Directory Not Found 

1. Should the Installation Directory not be found in the registry, user will see the pop 

up message shown in Figure 66.  

2. The  button will replace 

, until an 

Installation Directory has been re-specified.  

 

Figure 66: Database->Upgrade Database (Installation Directory Not Found) 

 

 
Figure 67: Database->Upgrade Database (Specify Installation Directory) 

 

3. Specify the Installation Directory by clicking   

3.1. A Dialog similar to the one shown in Figure 68 will appear.  

3.1.1. The default Installation Directory should be C:\Program Files\HWM-

Water\PermaHOST\ 

4. Once the installation directory has been specified.  
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4.1. A confirmation message similar to Figure 69 will be display for 5 seconds.  

4.2. will be replaced 

by  as shown 

in Figure 63.  

4.3. Continue with Procedure to Upgrade a Database Using Title Menu Option to complete 

database upgrade.  

 

 
Figure 68: Database-> Upgrade Database (Select the PermaHOST Application Installation 

Directory) - Only if prompted 

 

 
Figure 69: Database->Upgrade Database (Installation Directory Re-specified & Registry 

Updated) 
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 Database->Import Coronis XML File 

 

Database->Import Coronis XML File allows user import Coronis XML File/s into the 

application to populate the database automatically.  

 

Figure 70 shows the “PermaHOST Application: Import Coronis XML File” Dialog.  

User must select an XML file to open before the other buttons on the dialog become 

visible or enabled.  

 
Figure 70: Database->Import Coronis XML File (Default Dialog) 

 

If the imported XML file contains Applicative Acknowledge code:  

1. The logger serial, Level, Spread, Date and Leak Status will be written to the 

database.  

2. If the serial does not exist in the database, it will be created.  

3. If the serial exists and but logger history already written to the database for that 

date, the XML entry will be ignored.  

Procedure to Import Coronis XML File 

See Figure 70 and Figure 71 

1. Click on the  button  

1.1. When a XML File is selected: 

1.1.1. The XML file to be imported will be displayed in the text box.  
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1.1.2.  button will be activated once an XML File has been 

chosen.  

2. Click on the button , the status of the imported file progress will be 

shown in the text box below . 

2.1. will becomes visible to 

allow user to clear the import History text box.  

 

 

Figure 71: Database->Import Coronis XML File (Example Dialog) 
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 Database->Auto-Import Coronis XML File 

 

Database->Auto-Import Coronis XML File 

 

If this option has a � next to it, the application will check automatically every 3 

minutes and 20 second if Coronis XML folder contains any XML file/s to be 

extracted.  

1. If valid Coronis XML file/s exists in Coronis XML folder. The content of the file 

will be extracted and the XML file will be archived.  

1.1. Default location of Coronis XML folder is: C:\Program Files\HWM-Water 

Ltd\PermaHOST\Coronis XML 

1.1.1. This is the location where the XML file to be extracted automatically 

should be placed.  

1.2. Default location of Coronis XML Archive folder is C:\Program Files\HWM-

Water Ltd\PermaHOST\Coronis XML\Archive 

2. If the Coronis XML file in the Coronis XML folder is invalid or previously 

extracted already. The file will be archived to the unextracted folder.  

2.1. Default location of Coronis XML Unextracted Archive folder is C:\Program 

Files\HWM-Water Ltd\PermaHOST\Coronis XML\Unextracted XML 

Archive 

3. Where there is no next to this setting, any XML file in the Coronis XML File 

folder will not be extracted or archived.  
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 Help->About PermaHOST… 

Figure 72 explains what the various lines in About PermaHOST… mean: 

 

Application Version Number

Microsoft Access Database Number

Duration the Application has been running

HWM-Water Ltd Website

 

Figure 72: About PermaHOST... 
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 Unrecognised Messages 

Figure 73 shows the Data Pane view for Unrecognised Messages when Unrecognised 

Messages are selected in Location Pane. See Table 7 for a summary of the Data Pane 

Column of the Unrecognised Messages.  

Location Pane -> Unrecognised Messages
Bracket value at the right is the total number of unrecognised messages in the database.
(This value will not change even if date filter is applied) 

Data Pane -> Unrecognised Messages

Graphical Pane -> Unrecognised Messages

 

Figure 73: Unrecognised Messages 

All received messages that are not recognised by PermaHOST will be stored in 

Unrecognised Messages table in the database. Note a duplicated copy of this same 

message will be stored in Incoming messages.  

 

The user could sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

Table 7: Data Pane Columns for Unrecognised Messages 

ID This is an automatically generated number by the database. The latest received 

unrecognised message will have the largest ID number. 

Date/Time The date and time the message was received by the application. The date/time 

display format will be determined by the user selected date format described in 

Settings->Date Format. 

SIM The SIM card number that sent the message.   

Message The actual SMS Message received.  
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Location Pane->Unrecognised Messages->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane-> Unrecognised Messages->Clear All Unrecognised Messages 

This option erases all the unrecognised messages stored in the database. On user 

confirmation, 

1. The Unrecognised messages counter in Location Pane will be reset to zero 

2. All Unrecognised messages displayed in Data Pane will be erased.  

3. The Activity log file will be logged with the details of all deleted Unrecognised 

Messages.  

Location Pane-> Unrecognised Messages->Clear Incoming SMS Log File 

This option erases the content of the Incoming SMS Log File. On user confirmation, 

the Activity log file will log when the incoming SMS log was cleared.  

 

Data Pane->Unrecognised Messages->Context Menu 

In the Data Pane, the user has the option to right-click and selects one of the following 

options: 

Data Pane-> Unrecognised Messages->Copy 

This option will copy the message content of the selected unrecognised message onto 

the clipboard. The user could then choose to paste the copied content where they 

wish, e.g. paste into notepad.  

Data Pane-> Unrecognised Messages->Remove 

This option will remove the selected unrecognised message from the database. On 

removal: 

1. The Activity log is updated with the deleted message.  

2. The Unrecognised messages counter in Location Pane will be decremented by 1 to 

reflect the correct number of unrecognised messages left in the database.  
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 Received Messages 

Figure 74 shows the Data Pane view for Received Messages when Received 

Messages is selected in Location Pane. See Table 8 for a summary of the Data Pane 

Column of the Received Messages.  

Data Pane-> Received Messages

Graphical Pane ->Received Messages

Location Pane -> Received Messages

Bracket value at the right is the total number of received messages in the database.
(This value will not change even if date filter is applied) 

 

Figure 74: Received Messages 

All received messages by PermaHOST will be stored in the Received Messages table 

in the database. Note if the received message is not recognised by PermaHOST 

application, a duplicated copy of this same message will be stored in Unrecognised 

Messages.  

 

The user could sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

 

Table 8: Data Pane Columns for Received Messages 

ID This is an automatically generated number by the database. The latest received 

message will have the largest ID number. 

Date/Time The date and time the message was received by the application. The date/time 

display format will be dependent on the user selected date format described in 

Settings->Date Format. 

SIM The SIM card number that sent the message.   

Message The actual SMS Message received.  
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Location Pane->Received Messages->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane->Received Messages->Clear All Received Messages 

This option erases all the received messages stored in the database. On user 

confirmation, 

1. The Received messages counter in Location Pane will be reset to zero 

2. All Received messages displayed in Data Pane will be erased.  

3. The Activity log file will be logged with the details of all deleted Received 

Messages.  

Location Pane-> Received Messages->Clear Incoming SMS Log File 

This option erases the content of the Incoming SMS Log File. On user confirmation, 

1. The Activity log file will log when the incoming SMS log was cleared.  

 

Data Pane->Received Messages->Context Menu 

In the Data Pane, the user has the option to right-click and selects one of the following 

options: 

Data Pane-> Received Messages->Copy 

This option will copy the message content of the selected received message onto the 

clipboard. The user could then choose to paste the copied content where they wish, 

e.g. paste into notepad.  

Data Pane-> Received Messages->Remove Selected Message 

This option will remove the selected received message from the database. On 

removal: 

1. The Activity log is updated with the deleted message.  

2. The Received messages counter in Location Pane will be decremented by 1 to 

reflect the correct number of received messages left in the database.  

Data Pane-> Received Messages->Clear All Incoming Messages 

This option will remove all received messages from the database. On removal: 

1. The Received messages counter in Location Pane will be reset to zero 

2. All Received messages displayed in Data Pane will be erased.  
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3. The Activity log file will be logged with the details of all deleted Received 

Messages.  
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 Sent Messages 

Figure 75 shows the Data Pane view for Sent Messages when Sent Messages is 

selected in Location Pane. See Table 9 for a summary of the Data Pane Column of the 

Sent Messages:  

Data Pane-> Sent Messages

Graphical Pane-> Sent Messages

Location Pane -> Sent Messages
Bracket value at the right is the total number of sent messages in the database.
(This value will not change even if date filter is applied) 

 

Figure 75: Sent Messages 

All messages successfully sent by PermaHOST will be stored in Sent Messages table 

in the database.  

The user can sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

 

Table 9: Data Pane Columns for Sent Messages 

ID This is an automatically generated number by the database. The 

latest SENT message will have the largest ID number. 

Date/Time The date and time the message was sent by the application. The 

date/time display format is specified by the user selected date 

format described in Settings->Date Format. 

Message Type The type of message sent by PermaHOST Application. 

Destination SIM The SIM card number that PermaHOST application sent the 

message to.    

Message The actual SMS Message sent.  

SENT Message Status Always return “YES” as only messages sent successfully will be 

logged into the SENT message folder.  
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Location Pane->Sent Messages->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane->Sent Messages->Clear All Sent Messages 

This option erases all the messages sent, stored in the database. On user confirmation, 

1. The Sent messages counter in Location Pane will be reset to zero 

2. All Sent messages displayed in Data Pane will be erased.  

3. The Activity log file will be logged with the details of all deleted Sent Messages.  

Location Pane-> Sent Messages->Clear Outgoing SMS Log File 

This option erases the content of the Outgoing SMS Log File. On user confirmation, 

1. The Activity log file will log when the Outgoing SMS log was cleared.  

 

Data Pane->Sent Messages->Context Menu 

In the Data Pane, the user has the option to right-click and selects one of the following 

options: 

Data Pane-> Sent Messages->Copy 

This option will copy the message content of the selected sent message onto the 

clipboard. The user could then choose to paste the copied content where they wish, 

e.g. paste into notepad.  

Data Pane-> Sent Messages->Clear Selected Sent Message 

This option will remove the selected sent message from the database. On removal: 

1. The Activity log is updated with the deleted message.  

2. The Sent messages counter in Location Pane will be decremented by 1 to reflect 

the correct number of sent messages left in the database.  

Data Pane-> Sent Messages->Clear All Sent Messages 

This option will remove All SENT messages from the database. On removal: 

1. The Sent messages counter in Location Pane will be reset to zero 

2. All Sent messages displayed in Data Pane will be erased.  

3. The Activity log file will be logged with the details of all deleted Sent Messages.  
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 Failed Messages 

Figure 76 shows the Data Pane view for Failed Messages when Failed Messages is 

selected in Location Pane. See Table 10 for a summary of the Data Pane Column of 

the Failed Messages.  

Data Pane-> Failed Messages

Graphical Pane -> Failed Messages

Location Pane -> Failed Messages
Bracket value at the right is the total number of failed messages in the database.
(This value will not change even if date filter is applied) 

 

Figure 76: Failed Messages 

All messages unsuccessfully sent by PermaHOST will be stored in the Failed 

Messages table in the database.  

The user can sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

Table 10: Data Pane Columns for Failed Messages 

ID This is an automatically generated number by the database. The 

latest Failed message will have the largest ID number. 

Date/Time The date and time the message failed to be sent by the application. 

The date/time display format will be based on the user selected date 

format described in Settings->Date Format. 

Message Type The type of message failed to be sent by PermaHOST Application. 

Destination SIM The SIM card number that PermaHOST application failed to send 

the message to.    

Message The actual SMS Message that failed to be sent.  

SENT Message Status Always return “NO” as only message that failed to be sent will be 

logged into the FAILED message folder.  
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Location Pane->Failed Messages->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane->Failed Messages->Clear All Failed Messages 

This option erases all the messages that failed to be sent, stored in the database. On 

user confirmation, 

1. The Failed messages counter in Location Pane will be reset to zero 

2. All Failed messages displayed in Data Pane will be erased.  

3. The Activity log file will be logged with the details of all deleted Failed Messages.  

Location Pane-> Failed Messages->Clear Outgoing SMS Log File 

This option erases the content of the Outgoing SMS Log File. On user confirmation, 

1. The Activity log file will log when the Outgoing SMS log was cleared.  

 

Data Pane->Failed Messages->Context Menu 

In the Data Pane, the user has the option to right-click and selects one of the following 

options: 

Data Pane-> Failed Messages->Copy to Clipboard 

This option will copy the message content of the selected failed message onto the 

clipboard. The user could then choose to paste the copied content where they wish, 

e.g. paste into notepad.  

Data Pane-> Failed Messages->Remove Selected Failed Message 

This option will remove the selected failed message from the database. On removal: 

1. The Activity log is updated with the deleted message.  

2. The Failed messages counter in Location Pane will be decremented by 1 to reflect 

the correct number of failed messages left in the database.  

Data Pane-> Failed Messages->Send Selected Message Now 

This option will send the selected message and remove the selected message from the 

failed message table.  

1. The Failed messages counter in Location Pane will be decremented by 1 to reflect 

the correct number of failed messages left in the database.  
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2. On successfully sending the message, Sent messages counter will be incremented 

by 1. If however if the message failed to be sent, the failed messages counter will 

be re-incremented instead.  

3. The Activity log file will be logged with the details of the deleted Failed Messages.  
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 ALARMS Reports 

Figure 77 shows the Data Pane view for Alarms Reports when ALARMS is selected 

in the Location Pane. See Table 11 for a summary of the Data Pane Column of the 

Alarms Reports.  

Data Pane-> Alarm Reports

Graphical Pane ->Alarm Reports

Location Pane -> ALARMS
Bracket value at the right is the total number of Alarm Reports in the database.

(This value will not change even if date filter is applied) 

 

Figure 77: Alarms Reports 

All GNET messages with Alarm contents received successfully by PermaHOST will 

be stored in ALARM Report table in the database.  

 

The user can sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

Table 11: Data Pane Columns for ALARMS Reports 

EventID This is an automatically generated number by the database. The 

latest Alarm Report will have the largest ID number. 

PermaLog Serial (?) The Permalog logger Serial number with it unique alphabet 

identification.  

ECU No.  This number is used as the source ID for all leak-status messages 

sent via SMS.  

Currently, it is the last 4 digits of the PermaNet SMS Serial 

number. 

PermaNet Serial PermaNet SMS Serial Number 

PermaNet SMS Tel The PermaNet SMS SIM card number.  

Each PermaNet SMS will have a unique PermaNet SMS Telephone 

Number 
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Date/Time The date and time the Alarm report was received by the 

application. The date/time display format will be based on the user 

selected date format described in Settings->Date Format. 

Scheduled/Unscheduled The type of GNET message sent by PermaNet SMS.  

Scheduled means the PermaNet SMS unit was set to data report on 

the day the GNET message was received.  

Unscheduled means the PermaNet SMS unit was not set to data 

report on the day the GNET message was received.  

PermaNet SMS Alarm 

Type 

The type of PermaNet SMS Alarm. Could be one or all of the 

following: 

Low Battery    

Low GSM Signal Strength xxx% 

Permalog+ Alarm Type The type of Permalog+ Alarm. Could be one or three of the 

following 

Low Battery 

Low RF Signal Strength xxx% 

Leak to No Leak or No Leak to Leak 
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Location Pane->ALARMS->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane-> ALARMS->Export Alarms Histories 

This option allows the user to export all Alarms Reports in the database to CSV. An 

example of such a CSV file is shown below (Figure 78). 

 

Figure 78: ALARMS->Export Alarms Histories (to CSV file) 

Location Pane->ALARMS->Clear All Alarm Histories 

This option removes all Alarms Histories stored in the database.  

 

Data Pane->ALARMS->Context Menu 

In the Data Pane, the user has the option to right-click and selects one of the following 

options: 

Data Pane->ALARMS->Export Alarms Histories 

This option allows the user to export all Alarms Reports in the database to CSV. An 

example of such a CSV file is shown above (Figure 78). 

Data Pane->ALARMS->Delete Selected Alarm History 

This option will remove the selected Alarm report from the database. On removal: 

1. The Activity log is updated with the deleted alarm report  

2. The Alarm counter in Location Pane will be decremented by 1 to reflect the correct 

number of Alarms Reports left in the database.  

Data Pane->ALARMS->Print Alarm Histories 

This option will print the Alarm Histories displayed in the Data Pane.  
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Data Pane->ALARMS->Print Preview 

This option enables the user to check print layout without actually printing. It is the 

user’s responsibility to ensure that the pages fit into the user individual printer 

margins.  
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 PermaNet SMS 

Figure 79 shows the Data Pane view for the PermaNet SMS in the current database 

when the user selects PermaNet SMS in Location Pane. 

Data Pane-> PermaNET SMS

Graphical Pane -> PermaNET SMS

Location Pane -> PermaNET SMS
Bracket value at the right is the total number of PermaNET SMS Configurations stored in the database.
(This value will not change even if filters are applied) 

 

Figure 79: PermaNet SMS 

 

All PermaNet SMS configuration messages sent by any PermaNet SMS to 

PermaHOST (modem SIM number) will be decoded and stored into the PermaNet 

SMS Current Database.  

In the event that PermaHOST is expecting a Pending configuration from the 

PermaNet SMS, the Pending Table will be compared with the received configuration 

message.  

• In the event of a match, the Pending Configuration in the table will be deleted 

and the Current Configuration table will be updated.  

• In the event of a mismatch, the Current Table will be updated with the 

received configuration. And the Pending Configuration will be resent. 

PermaHOST will resend the Pending configuration for a maximum of 3 times 

(Resend will be done on each mismatched PermaNet SMS configuration 

message received). Thereafter, the user will be informed that the maximum 

number of retries has been exceeded and no further resending of the Pending 

configuration will be done by PermaHOST application, until the user specifies 

otherwise in the PermaNet SMS Setup dialog box shown in Figure 127. 

The user could sort the Data Pane columns by ascending or descending view based on 

what the user selected in the Data Pane column headings.  
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Table 12: Data Pane Columns for PermaNet SMS 

PermaNet 

Serial 

PermaNet SMS Serial Number  

ECU No. This number is used as the source ID for all leak-status messages sent via 

SMS.  

Currently, it is the last 4 digits of the PermaNet SMS Serial number.  

PermaNet 

SMS Tel 

The PermaNet SMS SIM card number.  

Each PermaNet SMS will have a unique PermaNet SMS Telephone Number 

Host PC Tel PermaHOST modem SIM card number.  

This is the number the PermaNet SMS is configured to send its Leak status 

message to.  

(Also known as NUM1)    

NUM2 Report-copy number.  

Whenever the PermaNet SMS is swiped with a magnet, this number will be 

sent a GNET message from the PermaNet SMS which has been reset.  

Patrol Days The days the PermaNet SMS is set to patrol for Permalog+ within its range.  

SMTWTFS refers to=>  

Sunday, Monday, Tuesday, Wednesday, Thursday, Friday & Saturday 

Example: If the device is set to Patrol only on Monday and Friday data pane 

will display Patrol Days as -M---F-. 

Patrol Start 

Time 

The time the PermaNet SMS is set to wake up on its Patrol Day/s. 

Time is shown in 24 hour format: hh:mm 

Patrol 

Duration 

(seconds) 

The period in seconds the PermaNet SMS is to stay awake for after its Patrol 

Start Time on a Patrol Day.  
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Duration ranges from 20 seconds to 120 seconds.  

Default is 30 seconds unless the user specified otherwise.  

Data Report 

Days 

The days the PermaNet SMS is set to wake up to send it Permalog+ 

Patrolled Data Reports in the PermaNet SMS Database.  

SMTWTFS refers to=>  

Sunday, Monday, Tuesday, Wednesday, Thursday, Friday & Saturday 

Example: If the device is set to send it data report only on Tuesday and 

Saturday data pane will display Data Report Days as --T---S. 

Data Report 

Time 

The time the PermaNet SMS is set to wake up on it Data Report Days. 

Time is shown in 24 hours format: hh:mm 

Pending 

Configuration? 

Yes = Pending configuration exists for the particular PermaNet SMS 

No = Pending configuration does not exist for the particular PermaNet SMS. 

Pending configuration of the particular PermaNet SMS could be viewed in 

the PermaNet SMS Setup dialog shown in Figure 127. 
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Location Pane->PermaNet SMS->Context Menu 

In the Location Pane, the user has the option to right-click and selects one of the 

following options: 

Location Pane-> PermaNet SMS ->Add PermaNet SMS Config 

This option opens the dialog box shown in Figure 80.  

Note: From PermaHOST 3.80 onwards, it is no longer necessary for the user to 

manually populate the PermaNet SMS Table.  

This could be handled automatically by PermaHOST without user input, the 

following procedures could be skipped if the user prefers to let PermaHOST 

handle the populating of the PermaNet SMS table in the database. 

The minimum requirement to get the PermaNet SMS to display itself on the PermaNet 

SMS Data Pane is to: 

1. Assign a PermaNet SMS Telephone Number 

2. Check the checkbox “Change PermaNet SMS Configuration (Update to Current 

Database only)” 

2.1. Note: The user must not select the option “Change PermaNet SMS 

Configuration (Update to Pending Database Send SMS)” 

2.1.1. This option should only be used if the user decides to reconfigure the 

PermaNet SMS.   

2.1.2. The user is strongly recommended to use Data Pane-> PermaNet SMS -

>Send SMS to get PermaNet SMS Configuration first or to allow PermaHOST to 

handle the process automatically (See Settings->Auto-Send SMS to 

Retrieve PermaNet SMS Config on Page 66) 

 

Figure 80: Location Pane->PermaNet SMS->Add PermaNet SMS Config 
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Note that the following are disabled or blanked:  

1. Permalog Loggers Linked 

1.1. No Permalog+ Logger could be linked because to link a PermaNet SMS, the 

SMS Telephone number must be defined first as mentioned in  Setup 

PermaNet SMS Dialog Explained. 

2. Update PermaNet SMS Information 

2.1. This option is totally disabled because this section is unique to a Permalog+. 

Accessing the Setup PermaNet SMS through this option does not allow 

entries as there is no linked Permalog+ logger.  

3. Pending PermaNet SMS Settings Radio button is disabled.  

4. PermaNet SMS Serial Number: Blank & Read only 

5. PermaNet SMS ECU Number: Blank & Read only 

6. PermaNet SMS Type (Required to know how to handle GNET messages) 

6.1. Default is “PALMER”; however, this value could be updated automatically 

by PermaHOST based on the received PermaNet SMS Configuration 

response messages.  

 

Location Pane-> PermaNet SMS ->Export PermaNet SMS Configurations to CSV 

This option allows the user to export all PermaNet SMS Configurations in the 

database to CSV. An example of such a CSV file is being shown below (Figure 81): 

 

Figure 81: PermaNet SMS-> Export PermaNet SMS Configurations to CSV 
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Data Pane->PermaNet SMS->Context Menu 

Note: There must be at least one PermaNet SMS configuration in the Data Pane 

before this context menu could be accessed.  

In the Data Pane the user has the option to right-click and selects one of the following 

options: 

Data Pane-> PermaNet SMS ->Delete Selected PermaNet SMS Configuration 

This option will remove the selected PermaNet SMS Configuration from the database. 

On removal: 

1. The Activity log is updated with the deleted Current configuration.   

2. The PermaNet SMS counter in Location Pane will be decremented by 1 to reflect 

the correct number of PermaNet SMS Configurations left in the database.  

Note if the PermaNet SMS to be deleted contains Pending Configuration, on removal: 

1. The Activity log is updated with the deleted Current and Pending Configuration. 

2. The PermaNet SMS counter in Location Pane will be decremented by 1 to reflect 

the correct number of PermaNet SMS Configurations left in the database.  

Data Pane-> PermaNet SMS ->Add New PermaNet SMS Configuration 

This option opens the dialog box shown in Figure 80.  

Please refer to Location Pane-> PermaNet SMS ->Add PermaNet SMS Config for an 

explanation of the dialog box.  

Data Pane-> PermaNet SMS ->Edit PermaNet SMS Configuration 

Note: The user is strongly recommended to use Data Pane-> PermaNet SMS ->Send SMS to 

get PermaNet SMS Configuration first before attempting to use the Data Pane-> PermaNet SMS 

->Edit PermaNet SMS Configuration. If using PermaHOST Version 3.80 onwards, the user 

is strongly recommended to allow PermaHOST to handle the populating of the 

PermaNet SMS Table.  

This option opens the dialog box shown in Figure 82. 
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Figure 82:  Data Pane->PermaNet SMS->Edit PermaNet SMS Configuration 

Displayed view: 

1. All Permalog+ loggers linked will be shown under Permalog Loggers Linked  

2. PermaNet SMS Serial Number (READ ONLY) 

3. PSR ECU Number (READ ONLY) 

4. Palmer SMS Type (Required to know how to handle GNET messages) 

4.1. PALMER will be selected for PermaNet SMS with firmware version from 

“Ver 01.00.03.00” onwards, provided a PermaNet SMS Configuration 

response was received by PermaHOST.  

5. Pending PermaNet SMS Settings Radio button is enabled if there is Pending 

Entry. 

6. PermaNet SMS Telephone Number (READ ONLY) 

7. Host PC Modem Number (NUM1) 

8. Mobile Number (NUM2) 

9. Patrol Settings  

10. Data Report Settings 

 

Note that the following are disabled or blanked:  

1. Update PermaNet SMS Information 
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1.1. This option is totally disabled because this section is unique to a Permalog+. 

Accessing the Setup PermaNet SMS through this option does not allow 

entries.  

1.2. From PermaHOST Version 3.80 onwards, the user could view this unique 

information of each logger by selecting the logger in Permalog Loggers 

Linked List.  

2. The Pending PermaNet SMS Settings option button is disabled if there is no 

Pending Entry. 

 

The user could edit or change the PermaNet SMS configuration here: 

To update to Current Database Only: 

1. Adjust the settings as required.  

2. Check the checkbox “Change PermaNet SMS Configuration (Update to Current 

Database only)” 

3. Click “OK” 

4. The updated PermaNet SMS Configurations should be updated on the screen.  

5. The Activity Log should be updated showing the configuration before and after 

the update.  

To update to Pending Database and send PermaNet SMS Configuration message to a 

PermaNet SMS: 

NOTE: This will reconfigure the PermaNet SMS Remotely. Do not attempt if you are 

unfamiliar with the Application. Example: Should the user accidentally reconfigure 

the PermaNet SMS to never wake up, the only way to rectify this is to go on-site to 

swipe the PermaNet SMS and reconfigure it on-site.  

1. Adjust the settings as required.  

2. Check the checkbox “Change PermaNet SMS Configuration (Update to Pending 

Database_Send SMS” 

3. Click “OK” 

4. The last column in the Data Pane “Pending Configuration?” view for the 

particular logger should change from “No” to “Yes”. 

5. Activity Log should be updated showing the changes to the current Configuration 

from “No” for Pending to “Yes” for Pending.   
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6. On the next original Data Report day for the particular PermaNet SMS to wake 

up, the PermaNet SMS will receive the reconfiguration message and reconfigure 

the PermaNet SMS. The PermaNet SMS will respond to the HOST PC with its 

configuration.  

7. On receiving the configuration response from the PermaNet SMS, PermaHOST 

will check the received entry for a match with the Pending database. 

7.1. If the Pending Configuration matches the received PermaNet SMS 

Configuration: 

7.1.1. Pending Configuration in the database will be deleted.  

7.1.2. Current database will be updated with the received configuration.  

7.1.3. Pending Status will revert to “No”. 

7.1.4. The Activity log will be updated with the changes.  

7.2. If the Pending Configuration does not match the received PermaNet SMS 

Configuration: 

7.2.1. The Pending Configuration will be resent by PermaHOST 

automatically each time the Configuration message failed to match the 

Pending configuration. However, PermaHOST will only repeat this 3 

times before warning the user of the failure to match the configuration.  

7.2.2. The Received PermaNet SMS configuration will be updated in the 

Current Table. There is no change to Pending Status so it remains as 

“Yes”. 

7.2.3. The Activity log will be updated with the changes.  

Data Pane-> PermaNet SMS ->Send SMS to get PermaNet SMS Configuration  

To use this option the user should: 

1. Select a PermaNet SMS in Data Pane to get the configuration of. 

2. Right-click on the selected PermaNet SMS in Data Pane.  

3. Click on the option “Send SMS to get PermaNet SMS Configuration”. 

4. Wait until the next data report day for the PermaNet SMS to respond to the 

configuration request (Note: Automatic from this point onwards) 

5. When PermaHOST receives the configuration response from the PermaNet SMS, 

the Received PermaNet SMS configuration will be updated to the Current Table.  

6. The Activity log will be updated with the changes.  
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Data Pane-> PermaNet SMS ->For Trained Engineer Use->PermaNet SMS Information
  

This option opens the dialog box shown in Figure 83. 

Note that this is a READ Only dialog box, where all displayed data, cannot be edited.  

1. “GET PermaNet SMS Status” Button 

1.1. Allows the user to query the PermaNet SMS for a new PermaNet SMS 

STATUS update.  

1.2. Note that an update will not be available until the next Data Report day of the 

selected PermaNet SMS 

2. “GET PermaNet SMS Firmware VERSION” Button 

2.1. Allows the user to query the selected PermaNet SMS for its current PermaNet 

SMS Firmware version number.  

2.2. Note that an update will not be available until the next Data Report day of the 

selected PermaNet SMS 

 

Figure 83: Data Pane-> PermaNet SMS ->For Trained Engineer Use->PermaNet SMS 

Information 
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Data Pane-> PermaNet SMS ->For Trained Engineer Use->PermaNet SMS Alarm 
Specification 

This option opens the dialog box shown in Figure 84 and allows the user to configure 

the selected PermaNet SMS Alarm Configurations.  

 

Figure 84: Data Pane-> PermaNet SMS ->For Trained Engineer Use->PermaNet SMS Alarm 

Specification 

 

Alarm configuration changes should be done only by trained engineers or PALMER.  

From Version 4.00 onwards,  Authorisation Code must be provided before user is 

allowed to change PermaNET SMS Alarm Configuration.  

1. PermaNet SMS Serial Number (READ ONLY) 

2. PermaNet SMS SIM Number (READ ONLY) 

3. GROUP “Alarm Configurations to be sent to PermaNet SMS on Confirmation”  

3.1. Alarm Config Last Update Date (READ ONLY) 

3.1.1. Blank if no PermaNet SMS Configuration message is ever received by 

PermaHOST.  

3.1.2. When the PermaNet SMS Configuration message response is received 

by PermaHOST, the Alarm configuration details are updated into the 

Alarm table. In this situation, the Alarm Config Last Update Date will 

have a date and time value. 
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3.1.3. “PENDING CONFIRMATION” this is shown when user has sent a 

request to confirm changes to Alarm Configuration of the selected 

PermaNet SMS Serial Number.  

3.1.4. The date/time is not displayed because it is of an older date/time than 

that of  “Alarm Config SMS Last Sent Date” 

3.1.5. Note the “Alarm Config SMS Last Sent Date” will have a date/time 

value in this situation.  

3.2. Alarm Config SMS Last Sent Date (READ ONLY) 

3.2.1. Blank if the user never sent out a request to change the selected 

PermaNet SMS Alarm Configuration.  

3.2.2. Date/time, contains the last date/time the user sent out a request to 

change the selected PermaNet SMS Alarm Configuration. 

3.2.3. If “Alarm Config Last Update Date” contains a date/time, the date/time 

will be of a more recent date than that of “Alarm Config SMS Last Sent 

Date”. 

3.3. P+ Low RF Signal Strength Alarm Threshold 

3.3.1. Allows the user to select a value in the range of 0 to 255, the threshold 

that Permalog Low RF Signal Strength should be flagged by PermaNet 

SMS to PermaHOST.  

3.4. GROUP “P+ Extraordinary Report (Enabled if checked)” 

3.4.1. Checkbox  

3.4.1.1. This option if checked, allows the PermaNet SMS to send a SMS 

on a date that it is not scheduled to Data Report, and notify the end 

user of a P+ having Low Battery status.  

3.4.2. Checkbox  

3.4.2.1. This allows the PermaNet SMS to send an SMS on a date that it is 

not scheduled to Data Report, and notify end user of a P+ having 

low RF Signal Strength status.  

3.4.3. Checkbox  

3.4.3.1. This allows the PermaNet SMS to send a SMS on a date that it is 

not scheduled to Data Report, and notify the end user of its 

(PermaNet SMS) Low Battery status.  
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3.5. Checkbox  (Default state 

recommended: Unchecked) 

3.5.1. Configure the PermaNet SMS to allow its configuration to be changed 

via Radio Frequency. 

3.6. Checkbox (Default state 

recommended: Unchecked) 

3.6.1. Configure the PermaNet SMS to allow its configuration to be changed 

via SMS.  

3.7. Checkbox  

3.7.1. If checked, the PermaNet SMS will send any SMS it received that is 

not recognised back to PermaHOST.  

3.8. GROUP “P+ Change of Leak-State Alarm” 

3.8.1. Checkbox  

3.8.2. Checkbox  

4. GROUP “PermaNet SMS GSM Signal Strength Alarm Settings” (This alarm is 

the only alarm not monitored by PermaNet SMS. If enabled, this alarm is 

monitored by PermaHOST) 

4.1. PermaNet SMS Low GSM Signal Strength Alarm Threshold 

4.1.1. Allows the user to select a value in the range of 0 to 31, the threshold 

that PermaNet SMS Low GSM Signal Strength should be flagged by 

PermaHOST to the end user.  

4.2. Checkbox  

4.2.1. The checkbox must be checked for PermaHOST to commence check 

on GSM Signal Strength. PermaHOST monitors and reports this alarm to 

the user on the screen if the GSM Signal Strength is below the specified 

threshold.  

5.  The correct  Authorisation Code 

needs to be entered, so that when the user clicks “OK”, the new alarm 

configuration will be sent to the PermaNET SMS.  

5.1. If the user opens the dialog box immediately, it will show “Alarm Config 

SMS Last Sent Date” as PENDING CONFIRMATION.  

6. “OK”  



PermaHOST Application Manual for Version 4.20 with Database Version 4.20  MAN-064-0002-E 

  PermaNet SMS – Context Menu Options 

HWM-Water Ltd (Palmer Environmental) – Your Gateway to the Latest Technology, Solutions 

and Services 

 

103 

6.1. If the correct  Authorisation Code has been entered. Clicking “OK” will 

send an Alarm Configuration message to the selected PermaNET SMS. 

6.2. If an incorrect  Authorisation Code has been entered. Clicking “OK” will 

result in a message pop up similar to Figure 85.  

 

 
Figure 85: PermaNET SMS - Alarm Configuration - Authorisation Code Error
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 Access Database 

Figure 86 shows the Data Pane view for an opened Access Database when the user 

selects the particular Access Database in Location Pane. 

 

Data Pane-> Access Database

Graphical Pane -> Access Database (Information)

Location Pane -> Access Database

 
Figure 86: Access Database 

 

Table 13: Data Pane Columns for Access Database 

Number of 

Areas/Regions 

This reflects the total number of Areas/Regions in the selected database.  

Number of Noise 

Loggers 

This reflects the total number of Permalog+ Noise Loggers in the 

selected database regardless of Areas/Regions.  

Number of Data 

Reports 

This reflects the total number of Permalog+ Noise Loggers Data 

Reports in the selected database regardless of Areas/Regions. 
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Location Pane->Access Database->Context Menu 

In the Location Pane users have the option to right-click and select one of the 

following options: 

Location Pane->Access Database->Add Areas/Regions 

This option allows the user to add a new Area/Region to the selected Access 

Database. Figure 87 shows the dialog box when the user chooses the option to Add 

Areas/Regions. 

 

Figure 87: New Areas/Regions Dialog box 

 

1. After the user entered a new Area/Region Name, the user must confirm to add the 

new area/region entered.  

2. On “OK”, a message will pop up with the message example: (See Figure 88) 

3. The Access Database Data Pane view will be updated automatically to reflect that 

the Number of Areas/Regions has incremented by 1. 

 

Figure 88: Added Successfully Region/Area Name: (Name of added area/region) 

Location Pane->Access Database->Close Access Database 

1. This option closes the selected Access Database 

Location Pane->Access Database->Host PC Telephone Number 

This option allows the user to define a HOST PC Telephone Number. If the HOST PC 

Telephone number is defined, it will automatically be entered into the PermaNet SMS 

Setup Dialog when the user chooses to add a new PermaNet SMS configuration. 
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Figure 89 shows the dialog box when the user chooses the option edit the Host PC 

Telephone Number (SIM). 

 

Figure 89: Host PC Telephone Number (SIM) Dialog Box 

Location Pane->Access Database->View Loggers in Leak State 

This option allows the user to view Active Loggers which are currently in Leak State 

as shown in Figure 90. 

If the user right-clicks on a logger displayed in this dialog box, the user will be able to 

Modify Logger Status and View Logger Status, of the selected logger.  

For Modify Logger Status, refer to Location Pane->Database Loggers ->Modify Logger 

Details  

For View Logger Status, refer to Location Pane->Database Loggers ->View Logger Details 

 

Figure 90: Location Pane->Access Database->View Loggers in Leak State 
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 View Loggers in Leak State-> Export to CSV Button 

 

Figure 90 shows the View Loggers in Leak State Dialog. In this dialog there is a 

button option to Export to CSV. When the user clicks on this button, a CSV file 

similar to the one show in Figure 91 will be generated.  

 

Figure 91: View Active Loggers in Leak State -> Export to CSV Button
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 Database Area/Region 

When the user selects the particular Access Database Area/Region in the Location 

Pane, Figure 92 shows the Data Pane view for the opened Access Database 

Area/Region. 

 

Data Pane-> Database Area/Region

Graphical Pane ->Database Area/Region (Information)

Location Pane -> Database Area/Region

 
Figure 92: Database Area/Region 

 
Table 14: Data Pane Columns for Access Database Area/Region 

Number of 

PermaLogs 

This reflects the total number of Permalog+ loggers in the selected 

Area/Region.  

Number of Data 

Reports 

This reflects the total number of Permalog+ Noise Loggers Data 

Reports in the selected Area/Region. 
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Location Pane->Database Area/Region->Context Menu 

In the Location Pane, the users have the option to right-click and select one of the 

following options: 

Location Pane->Database Area/Region->Add Logger 

This option allows the user to add a Permalog+ logger to the selected Database 

selected Area/Region. Figure 93 shows the dialog box when the user chooses the 

option Add Logger. 

1. If a user wishes to link the logger to a PermaNet SMS (Regardless of whether the 

PermaNet SMS is already defined or not), the PermaNet SMS Telephone number 

should be defined under the edit box for “PermaNet SMS Telephone Number”.  

2. The minimum requirement to add a logger to the PermaHOST application is to at 

least assign the Serial Number of the Permalog+ logger.  

3. The Location number should be no more than 8 digits (numbers only to be used 

with PermaLog PC Software.)  

4. Optional entries for: 

4.1. Location Number 

4.2. Address1 

4.3. Address2 

4.4. PermaNet SMS Telephone Number 

4.5. Leak Threshold Adjustment (Pipe Sensitivity) 

4.6. Notes 

 

Figure 93: New Logger Dialog Box 
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Location Pane->Database Area/Region->Export Area/Region Loggers Data Report to 

CSV 

This option allows the user to export the selected Area/Region Permalog+ loggers 

Data Report to CSV. An example of such a CSV file is shown below (Figure 94 and 

Figure 95):  

 

Figure 94: Database Area/Region->Export Area/Region Loggers Data Report to CSV (Notepad 

view) 

 

Figure 95: Database Area/Region->Export Area/Region Loggers Data Report to CSV (Excel 

view) 

The exported file can be opened in notepad, excel, etc.  

Note the date format saved to the file will be based on user selected Date Format, 

covered in Settings->Date Format. 
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Location Pane->Database Area/Region->Export Area/Region Loggers Details to CSV 

This option allows the user to export the selected Area/Region Permalog+ loggers 

Details to CSV. An example of such a CSV file is shown below (Figure 96): 

 

Figure 96: Database Area/Region->Export Area/Region Loggers Details to CSV 

The exported file could be opened in notepad, excel, etc. 

Note the date format saved to the file will be based on user selected Date Format, 

covered in Settings->Date Format. 

 

Location Pane->Database Area/Region->Export Active Loggers Details & Data Report 

to PermaLog CSV 

This option allows the user to export the selected Area/Region ACTIVE Permalog+ 

loggers Details to CSV. Only ACTIVE loggers are allowed to be exported because 

Permalog+ PC Software does not allow duplicated Serial Numbers. An example of 

such a CSV file is shown below (Figure 97): 

 

Figure 97: Database Area/Region->Export Active Loggers Details & Data Report to PermaLog 

Software CSV 

The exported file can be opened in notepad, excel, Permalog+ Software, etc. 

Note the date format saved will be in the required format for PermaLog+ Software. 

Therefore the required saved format will be DD/MM/YYYY. 
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Location Pane->Database Area/Region->Export Active Loggers Telephone Numbers to 

CSV 

This option allows the user to export the selected Area/Region ACTIVE Permalog+ 

loggers Telephone Numbers to CSV. An example of such a CSV file is shown below 

(Figure 98): 

 

Figure 98: Database Area/Region->Export Active Loggers Telephone Numbers to CSV 

Location Pane->Database Area/Region->Rename Area/Region 

This option allows the user to rename an existing Area/Region to a different name.  

When the user chooses the option to rename the selected Area/Region, a dialog box 

similar to the one shown in Figure 99 is shown. 

 

Figure 99: Database Area/Region->Rename Area/Region 

If the user enters a new Area/Region name and clicks “OK”: 

1. A message pop up will inform the user of the updated Area/Region name.  

2. The Activity log will log the changes in Area/Region Name by the user.  

Location Pane->Database Area/Region->Remove Area/Region 

This option allows the user to remove an existing Area/Region.  

Note that choosing this option will remove all loggers within the area/region, and any 

information related to the loggers, including data reports.  

When this option is selected: 

1. The user will be prompted with “Are you sure?” 

2. On confirmation “Yes” the selected Area/Region to be removed will disappear 

from the application screen.  

3. The Activity log will be logged with a log of area/region removed, along with all 

its related loggers, unique information and data reports.  
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Location Pane->Database Area/Region->INACTIVATE All Loggers in Selected 

Area/Region 

This option allows the user to inactivate all loggers in a selected Area/Region. 

Location Pane->Database Area/Region->Selective Activation/Deactivation of logger in 

Area/Region 

This option allows the user to selectively activate or deactivate loggers within a 

particular Area/Region. See Figure 100.  

 

Figure 100: Location Pane->Database Area/Region->Selective Activation/Deactivation of logger 

in Area/Region 

 

To use Area/Region Loggers Activation or Deactivation Dialog: 

1. The user needs to select either radio buttons  or 

.  

2. The Activity status of loggers in the Left List is specified by list name on top.  

2.1. Clicking on a logger in the Left List will display its Location Number, 

Address1, Address 2 and Additional Information. See example shown in Figure 

100. 
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3. The list on the Right will hold loggers which the user had selected to possibly 

change their activity status.  

4. To proceed to change the activity status of the loggers in the Right List, the user 

must: 

4.1. Check the checkbox . 

4.2. Click , which will be enabled with the checking of the above 

checkbox. 

 

Location Pane->Database Area/Region->Change Pipe Sensitivity of All Loggers in 

Selected Area/Region 

This option allows the user to change the pipe sensitivity of All Loggers in a Selected 

Area/Region.  Authorisation Code is required to use this option.  

See Figure 101. 

 
Figure 101: Location Pane->Database Area/Region->Change Pipe Sensitivity of All Loggers in 

Selected Area/Region 

 
To use Change Pipe Sensitivity of All Loggers in Selected Area/Region Dialog: 

1. Select one of the following radio buttons: ,  or  

2. Once selected, select the required Pipe Sensitivity to Apply.  

3. Enter the correct  Authorisation Code. 

4. Click “OK”. 

With the correct  Authorisation Code, the pipe sensitivity of loggers in a selected 

Area/Region could be changed and applied immediately.  
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 Database Loggers 

Figure 17 shows the Data Pane view for a selected PermaLog+ Logger. 

The user can sort the Data Pane columns by ascending or descending view based on 

what the user selects in the Data Pane column headings.  

Table 15: Data Pane Columns for Permalog+ Logger 

Event ID This value is automatically normalized by the application to start at 1. 

The latest Data Report will have the largest ID number. 

Note this value is not the same as the automatically generated number 

by the database. The latest Data Report will have the largest ID 

number. 

Status Indicate Leak Status (For Normal Pipe Sensitivity):  

Indicate No Leak Status (For Normal Pipe Sensitivity):  

Indicate Leak Status (For Custom Pipe Sensitivity):  

Indicate No Leak Status (For Custom Pipe Sensitivity):  

Date The date the data report is received. The date display format will be 

based on the user selected date format described in Settings->Date 

Format. 

Level Level range 0 to 99 

Spread  Spread range 0 to 99 

Msg Type The type of GNET message sent by PermaNet SMS.  

• Scheduled means the PermaNet SMS unit was set to data 

report on the day the GNET message was received. 

Unscheduled means the PermaNet SMS unit was not set to 

data report on the day the GNET message was received.  

P+ Battery For PermaNet SMS Firmware pre-version Ver 01.00.03.00 

• Blank (no information) 

For PermaNet SMS Firmware Version from Ver 01.00.03.00 
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• OK 

• LOW 

P+ RF Signal For PermaNet SMS Firmware pre-version Ver 01.00.03.00 

• Blank (no information) 

For PermaNet SMS Firmware Version from Ver 01.00.03.00 

• xxx% 

PermaNet Battery For PermaNet SMS Firmware pre-version Ver 01.00.03.00 

• Blank (no information) 

For PermaNet SMS Firmware Version from Ver 01.00.03.00 

• OK 

• LOW 

PermaNet RSSI For PermaNet SMS Firmware pre-version Ver 01.00.03.00 

• Blank (no information) 

For PermaNet SMS Firmware Version from Ver 01.00.03.00 

• xxx% 

Alarm Status Indicates if there is Alarm if the alarm is that of: 

1. PermaNet SMS Alarm 

2. PermaLog Alarm 

3. PermaNet & PermaLog Alarm 
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Location Pane->Database Loggers->Context Menu 

In Location Pane, the user has the option to right-click and selects one of the 

following options: 

 

The following note applies to both Location Pane->Database Loggers ->View Logger Details 

& Location Pane->Database Loggers ->Modify Logger Details 

Note that from Version 3.80 onwards, when either of the above options is selected, if 

the PermaNet SMS SIM number has been entered but the PermaNet SMS Serial 

Number is empty, should Settings->Auto-Send SMS to Retrieve PermaNet SMS 

Config be enabled, PermaHOST will automatically send a configuration request SMS 

to the PermaNet SMS. This will only be done once automatically by PermaHOST for 

each unique PermaNet SMS SIM number.  

Location Pane->Database Loggers ->View Logger Details 

This option allows the user to view the details of an existing Logger. Figure 102 

shows an example of the dialog box, when the user chooses the option to View 

Logger Details for a specific Logger.  

 

Figure 102: Database Logger->View Logger Details
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Location Pane->Database Loggers ->Modify Logger Details 

This option allows the user to modify the details of an existing Logger. Figure 103 

shows an example of the dialog box, when the user chooses the option to Modify 

Logger Details for a specific Logger.  

 

NOTE:  

1. Should the user wish to assign/change the logger PermaNet SMS Telephone 

Number, the user should use “Modify Logger Details” option to do so.  

2. The user assigned PermaNET SMS SIM Number will be automatically 

overwritten, if the logger is reported by another PermaNET SMS SIM Number.  

2.1. This is to take into account that the user’s manual entry could be erroneous.  

3. From Application version 4.00 onwards, to change the Pipe Sensitivity of a logger, 

user must enter the correct  Authorisation Code first.  

 

When the logger details have been modified, the Activity Log will have a log of these 

changes.  

 

Figure 103: Database Logger->Modify Logger Details 
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Location Pane->Database Loggers ->Export Logger Data Report to CSV 

This option allows the user to export the selected logger’s data report to CSV. An 

example of such a CSV file is shown below (Figure 104): 

 

Figure 104: Database Loggers->Export Logger Data Report to CSV 

 

The exported file can be opened in notepad, excel, etc. 

Note that the date format saved to the file will be based on user selected Date Format, 

covered in Settings->Date Format. 
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Location Pane->Database Loggers ->Setup PermaNet SMS 

This option allows the user to use all the features mentioned in  Setup PermaNet 

SMS Dialog Explained. Additionally, the users are able to enter Unique PermaNet 

SMS Information linked with the selected Permalog+ logger.  

Notice from Figure 105 that unlike Figure 127 “Update PermaNet SMS Information” 

is enabled.  

The user can edit this information which is unique to the selected Permalog+ logger 

only.  

 
All other options are the same as described in 

 Setup PermaNet SMS Dialog Explained (Page 150). 

 

Note: The minimum requirement to enter unique PermaNet SMS information should 

the PermaNet SMS not be defined is to define the PermaNet SMS Telephone Number. 

 

Note: From PermaHOST Version 3.80 onwards, the user could rely on PermaHOST 

to automatically populate the PermaNet SMS table provided Settings->Auto-Send 

SMS to Retrieve PermaNet SMS Config has a � next to it.  

E.g.  

• To confirm unique information entry, click  

• To delete unique information, click  

o Activity log will be logged with the deleted PermaNet SMS 

Information.  
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Figure 105: Database Loggers->Setup PermaNet SMS 
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Location Pane->Database Loggers ->Move Logger to Another Area/Region 

This option allows the user to move a selected logger with or without its Data Report 

to another Area/Region within the same database. Figure 106 shows the dialog that 

will pop up when the user selects this option.  

 

Figure 106: Database Loggers->Move Logger to Another Area/Region 

 

To move the logger with its data report, the user must not check the checkbox 

 

• This option will move the logger as it is with it existing Serial Alphabet 

To move the logger without its data report, the user must check the checkbox  

 

• With this option the original Serial Alphabet will remain in its original 

Area/Region.  

• The next available Alphabet for the particular serial number will be added to 

the required region to move to. Note that the status information of the 

Permalog will be available in this Area/Region as well.  

• Also the shifted logger will be made the active logger, should there be no 

active logger with the same serial number at all.  
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Location Pane->Database Loggers ->Make Logger Active 

This option allows the user to make a selected Logger an ACTIVE logger if it is in 

INACTIVE state.  

1. When the user right-clicks on an INACTIVE logger and selects “Make Logger 

Active” 

2. All other loggers with the same 8 digit serial number will be deactivated.  

3. The selected logger to be activated will become the active logger in the 

Location Pane display.  

4. The Activity Log will log the date and time the logger was activated 

Location Pane->Database Loggers ->Make Logger Inactive 

This option allows the user to make a selected Logger an INACTIVE logger if it is in 

ACTIVE state.  

1. When the user right-clicks on an INACTIVE logger and selects “Make Logger 

Inactive” 

2. A pop up menu similar to the one shown in Figure 107 will be shown.  

3. The Activity Log will log the date and time the logger was deactivated 

 

Figure 107: Database Loggers->Make Logger Inactive confirmation popup 

 

Location Pane->Database Loggers ->Delete Logger 

This option allows the user to delete a selected logger.  

1. On confirmation to delete, the location will reflect the fact that the logger has 

been removed.  

2. The Activity log will reflect the Permalog+ Status, PermaNet SMS Unique 

Info (if it exists) and Permalog+ Data report/s deleted.  
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Location Pane->Database Loggers ->Manually Add/Change Level & Spread History 

 

Figure 108 shows the dialog for Manual Leak History Entry.  

Note:  

1. The user will be able to create a new entry. 

1.1. The user will not be permitted to create a new entry for a future date.  

2. The user will be able to update an existing entry. 

 

 
Figure 108: Location Pane->Database Loggers ->Manually Add/Change Level & Spread History 

 

Procedure to Use Manual Leak History Entry Dialog: 

1. Select a date from the calendar.  

1.1. If an entry already existed, it Level and Spread information will be displayed.  

1.1.1. E.g. See Figure 109.  

1.2. The user must check the  checkbox in 

order to permit overwriting of an existing entry.  

2. Select a Level 0 to 99 

3. Select a Spread 0 to 99 

4. Enter the  Authorisation Code 

5. Click  

5.1. The entry would be added to the Main Application Data Pane and the Manual 

Leak History Entry dialog box will remains open.  
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6. To add or overwrite another entry, just repeat the procedure above. Otherwise click 

 to return to the main Application Screen.  

6.1. An example of the database view is shown in Figure 110.  

6.1.1. Notice that Msg Type displayed “Manual Entry” and “Manual 

Overwrite”. This is to help the user differentiate between Level & Spread 

received from PermaNET SMS and Level & Spread entered by the user.  

 

 

Figure 109: Location Pane->Database Loggers ->Manually Add/Change Level & Spread History 

(Entry Exists) 

 

 
Figure 110: Data Pane View after History Manual Overwrite & New History Entry Added 
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Data Pane->Database Loggers->Context Menu 

In the Data Pane the user has the option to right-click and selects one of the following 

options: 

Data Pane->Database Loggers->Print Data Report 

1. Right-click on the data pane, and select “Print Data Report” 

2. The Print dialog will be shown. 

3. To print, click “Print”. (Use print preview prior to printing to check that the 

printer setup is correct. If not you will need to correct accordingly) 

Data Pane->Database Loggers->Print Preview 

1. Right-click on the data pane, and select “Print Preview” 

2. A preview of the print layout of the data report will appear on the screen. 

Data Pane->Database Loggers->Delete Selected Data Report 

1. Right-click on a data report in the data pane. Select “Delete Selected Data 

Report” 

2. The selected data report is deleted from the data pane.  

3. Check the Activity log to ensure that the selected data report deleted is logged 

in the Activity log. 

 

Graphical Pane->Database Loggers->Context Menu 

In the Graphical Pane, the user has the option to right-click and select one of the 

following options: 

Graphical Pane->Database Loggers->Print Graph 

1. Right-click on the graphical pane, and select “Print Graph” 

2. The Print dialog should be shown on the screen. 

3. Click print. 

(Note: currently it takes approximately 8 minutes to ‘print graph’ a fully populated 

graph) 

Graphical Pane ->Database Loggers->Print Preview 

1. Right-click on the graphical pane, and select “Print Preview” 
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2. A preview of the print layout of the graph will appear on the screen. (Note the 

graphical pane print preview is for guidance only) 
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 View Filters Information Dialog Box 

The Filter Information Dialog box shown in Figure 111 can only be viewed if there is 

at least one filter active, as the only way to get to this dialog is to click the  icon. 

 

Figure 111: View Filters Information Dialog Box 

The user can select any combination of filters and activate them directly from this 

dialog box.  

1. Date Filtering 

1.1. When checked, this will generate the date filtering dialog box shown in 

Figure 57. See View->Filters->Date Range for details on how to use this dialog 

box.  

2. PermaNet SMS SIM or Serial Number Filtering 

2.1. When checked, this will generate the PermaNet SMS Number filtering dialog 

box shown in Figure 59. See View->Filters->PermaNet SMS Number (SIM/Serial) for 

details of how to use this dialog box.  

3. PermaLog Loggers Specific Filters 

3.1. Location Number Filtering 

3.1.1. When checked, this will generate the Location Number filtering dialog 

box shown in Figure 60. See View->Filters->Location Number for details of 

how to use this dialog box.  

3.2. Leak/No Leak Filtering 

3.2.1. Note that for Leak/No Leak Filtering; at any one time, only Leak or No 

Leak can be selected. Checking one option will automatically uncheck 

the other option, if the other option is already checked.  
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3.3. Active/Inactive Filtering 

3.3.1. Note that for Active/Inactive Filtering, at any one time, only Filter by 

Active Loggers or Filter by Inactive Loggers can be selected. Checking 

one option will automatically uncheck the other option, if the other 

option is already checked. 
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 PermaHOST Summary Screen Dialog Box 

The PermaHOST Summary Screen is shown when the Application first start up. 

Should the user wish to access the summary screen during normal operation, the user 

should select the Summary screen icon (see Figure 112) available in the Toolbar.  

 

Figure 112: Summary Screen Icon in Toolbar 

Clicking on the summary screen icon will result in the dialog box shown in Figure 

113.

 

Figure 113: PermaHOST Summary Screen – Current Status Overview Page 

 

To display this summary screen in a specific date format if running the application for 

the first time: 

1. Click “OK” to close the summary screen.  

2. Follow the instruction in Settings->Date Format 

3. Open the summary screen again by selecting the icon shown in Figure 112. 

NOTE: It is important to note that any filters that the user applied in the main 

PermaHOST application will not apply within the PermaHOST Summary Screen. The 

PermaHOST Summary screen displays all ACTIVE Permalogs, regardless of user 

activated filtering. Individual filtering could be performed within certain pages in this 

TAB style dialog.  
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Current Status Overview Page 

The Current Status Overview Page is the main page of the PermaHOST Summary 

Screen. Through this page, the user can access the Sensors Page and Devices 

Administration Page by clicking the respective tab.  

The Current Status Overview Page shown in Figure 113 is split into two main 

sections: 

1. Number of PermaLog Units 

1.1. Registered PermaLogs 

1.1.1. Displays the number of registered PermaLogs in the database.  

1.1.2. A PermaLog is considered registered if at least one of the following are 

available in the PermaLog Status 

1.1.2.1.Address 1, Address 2 or Location Number. 

1.1.3. Clicking on the  button will take the user to 

the Devices Administration Page containing the Registered Permalogs 

Page 

1.2. Unregistered/New PermaLogs 

1.2.1. Displays the number of unregistered PermaLogs in the database.  

1.2.2. A PermaLog is unregistered if it does not contain all of the following 

fields are incomplete in its PermaLog Status 

1.2.2.1.Address 1, Address 2 and Location Number.  

1.2.3. Clicking on the  button will take the 

user to the Devices Administration Page containing the 

Unregistered/New Permalogs Page 

1.3. Total PermaLogs 

1.3.1. Displays the total number of registered and unregistered/new 

PermaLogs in the database. 

1.3.2. Clicking on the  button will take the user to the 

Devices Administration Page containing the Total Permalogs Page 

2. Number of PermaLog Units Indicated Leak 

2.1. Total PermaLogs Indicated Leak 

2.1.1. Displays the total number of PermaLogs with their latest data history 

indicating leak.  
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2.1.2. Clicking on the  button will take the user to the 

Sensors Page containing the Permalogs Page. 

2.1.2.1.Note that only PermaLogs in Leak will be displayed in this 

particular situation.   

2.2. The Newest Leak Date 

2.2.1. Displays the latest Leak date from the latest data history, detected in 

the database 

2.3. The Oldest Leak Date 

2.3.1. Displays the oldest Leak date from the latest data history, detected in 

the database 
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Summary Screen – Devices Administration Page and Sensors Page 

Context Menu Options 

 

The Context Menu Options shown in Figure 114 is accessible by right-clicking on a 

particular Permalog in the list.  

 

 

Figure 114: Summary Screen Context Menu Options 

 

1. Modify Logger Status 

1.1. See Location Pane->Database Loggers ->Modify Logger Details on how to use this 

dialog. 

1.2. Any changes made will be reflected on the screen immediately.  

2. View Logger Status 

2.1. See Location Pane->Database Loggers ->View Logger Details on how to use this 

dialog. 

3. Show History 

3.1. Data Reports History of selected logger will be displayed in the “Requested 

Permalog History” Page. See Figure 118. 

3.2. To return to the Sensors Page – Permalogs Page, just select the Permalogs 

Tab.  
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Sensors Page 

 

The Sensors Page is split into two sub-pages: 

1. Permalogs Page (Page 135) 

2. Requested Permalog History Page (Page 139) 

 

See Figure 115. 

 

Figure 115: PermaHOST Summary Screen – Sensors Page - Permalogs Page 
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Sensors Page – Permalogs Page 

Figure 115 shows the Permalogs Page within the Sensor Page.  

Table 16 explains the individual columns shown in the Permalogs Page within 

Sensors Page.  

The user will be able to sort the column by ascending/descending order by clicking on 

a column heading.  

Note that when the user chooses to use the “Search For” option within this dialog box, 

the search result will be displayed in this page. Notice from Figure 115 that the  

 and   buttons are disabled.  

1. The Records text box will reflect the total number of records being displayed on 

the screen.  

2.  will export the displayed list to a CSV formatted file.  

2.1. See Figure 116. 

3. The  button is enabled when the user selects an item in the “Search For” 

Combo box. 

4. The  button is enabled when an actual search has been performed. When 

the  button is enabled, the  button is disabled. Figure 117 shows 

an example of a search performed for Level > 35. Notice that the  button 

is enabled and the  combo 

boxes and Search button has been disabled.  

4.1. Clicking on the  button will return the user to the display whereby 

no Summary Screen filter has been applied.  

5. The “Search For” option will allow the user to search by: 

5.1. Serial Alphabet – All available serial alphabets in the database will be 

displayed in the combo list next to the search for combo list.  

5.2. Leak  

5.3. Days in Leak – All available days in leak in the database will be displayed in 

the combo list next to the “Search For” combo list.  

5.4. From Date – The user could select a date from the Date Picker on the left-

hand side of the Search button.  
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5.5. Level > than – Range 0 to 99 

5.6. Level < than – Range 0 to 99 

5.7. Spread > than – Range 0 to 99 

5.8. Spread < than – Range 0 to 99 

5.9. P+ RF Signal < than – Range 0% to 100% 

5.10. P+ RF Signal > than – Range 0% to 100% 

5.11. Location Number - All available Location Numbers in the database 

will be displayed in the combo list next to the search for combo list.  

5.12. Address 1 – All available Address 1 in the database will be displayed 

in the combo list next to the “Search For” combo list. 

5.13. Address 2 - All available Address 2 in the database will be displayed in 

the combo list next to the search for combo list. 

5.14. Pipe Sensitivity – All available Pipe Sensitivity in the database will be 

displayed in the combo list next to the “Search For” combo list.  

6. Context Menus: Accessible by right-clicking on a particular Permalog in the list.  

6.1. See Summary Screen – Devices Administration Page and Sensors Page 

Context Menu Options (Page 133) 

 

 
Figure 116: Summary Screen - Sensors - Permalogs - Export to CSV 
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Table 16: Columns for PermaHOST Summary Screen – Sensors Page - Permalogs Page 

Serial Alphabet The Permalog logger Serial number with its unique alphabet 

identification. 

Date This date indicates the latest date the particular logger is in leak. 

Leak  Displays the leak image: or  

Days in Leak The number of Days the logger is in Leak. 

Note that this information will not be available if the logger is not 

in leak or, if the database hasn’t been updated correctly to work 

with PermaHOST 4.00 database.  

Level The latest Leak Report Level value (0 to 99) 

Spread The latest Leak Report Spread value ( 0 to 99) 

P+ RF Signal The latest Leak Report P+ Radio Frequency Signal Strength, 

displayed as percentage.  

P+ Battery The latest Leak Report P+ Battery Status: OK or LOW 

Pipe Sensitivity The sensitivity of the pipe. Range from 50% to 150% sensitivity.  

If the Pipe Sensitivity is not default 100% sensitivity, the leak 

status of the logger is calculated by PermaHOST.  

Location Number The P+ Status information: Location Number 

Address 1 The P+ Status information: Address 1 

Address 2 The P+ Status information: Address 2 
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Figure 117: PermaHOST Summary Screen – Sensors Page - Permalogs Page - Search For Level 

> 35
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Sensors Page – Requested Permalog History Page 

Figure 118 shows the Requested Permalog History Page within Sensor Page. Table 

17 explains the individual columns shown in the Requested Permalog History Page 

within the Sensors Page.  

Above the history list display is the Permalog Status information stored in the 

database. See Figure 118 for clarification. Permalog Status information displayed 

includes:  

1. Serial Alphabet of the logger 

history being displayed.  

2. Deployed, the date the logger was 

deployed by the user or first 

detected by PermaHOST.  

3. Location Number 

4. Address 1 

5. Address 2 

6. Notes, also known as Additional 

Information. 

7. Pipe Sensitivity of the logger, if the 

value is not default 100%, the leak 

status is determined by 

PermaHOST, based on the 

sensitivity set by the user.   

 
Figure 118: Summary Screen – Sensors Page - Requested Permalog History Page 

 

The user will be able to sort the column by ascending/descending order by clicking on 

a column heading.  
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Note that when the user chooses to use the “Search For” option within this dialog box, 

the search result will be displayed in this page. Notice from Figure 118 that the  

 button is disabled.  

1. The Records textbox will reflect the total number of records being displayed on 

the screen.  

2. The  button will export the displayed list to a CSV formatted file.  

2.1. The CSV file could be saved using the default file name provided by 

PermaHOST xxxxxxxx (x)-permalog-hist.csv 

2.2. See Figure 119. 

3.  The  button is enabled when an actual search has been performed. When 

the  button is enabled, the  button is disabled. Figure 120 shows 

an example of a search performed for Leak. Notice that the  button is 

enabled and the combo 

boxes and button have been disabled.  

3.1. Clicking on the  button will return the user to the display whereby no 

Summary Screen filter has been applied.  

4. The “Search For” Option will allow the user to search by: 

4.1. Leak  

4.2. Level < than – Range 0 to 99 

4.3. Level > than – Range 0 to 99 

4.4. Spread < than – Range 0 to 99 

4.5. Spread > than – Range 0 to 99 

4.6. P+ RF Signal < than – Range 0% to 100% 

4.7. P+ RF Signal > than – Range 0% to 100% 

4.8. P+ Battery – All available choices in the database will be displayed in the 

combo list next to the “Search For” combo list. This will only display either 

“OK” or “LOW”. 

4.9. Greater than Date - The user could select a date from the Date Picker on the 

left-hand side of the Search button. 

4.10. Older than Date – The user can select a date from the Date Picker on 

the left-hand side of the Search button.  
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Table 17: Columns for PermaHOST Summary Screen – Sensors Page – Requested Permalog 

History Page 

Date The date the particular permalog history was logged.  

Status  Displays the leak image (For Normal Pipe Sensitivity): or  

Displays the leak image (For Custom Pipe Sensitivity):  or  

Level The latest Leak Report Level value (0 to 99) 

Spread The latest Leak Report Spread value ( 0 to 99) 

P+ RF Signal The latest Leak Report P+ Radio Frequency Signal Strength, 

displayed as percentage.  

P+ Battery The latest Leak Report P+ Battery Status: OK or LOW 

 

 
Figure 119: Summary Screen - Sensors - Requested Permalog History - Export to CSV 



PermaHOST Application Manual for Version 4.20 with Database Version 4.20  MAN-064-0002-E 

 PermaHOST Summary Screen Dialog Box – Sensors Page – Requested PermalogHistory 

Page 

HWM-Water Ltd (Palmer Environmental) – Your Gateway to the Latest Technology, Solutions 

and Services 

 

142 

 

 
Figure 120: PermaHOST Summary Screen – Sensors Page - Requested Permalog History Page - 

Search For Leak 
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Devices Administration Page 

The Devices Administration Page is split into five sub-pages: 

1. Total Permalogs Page (Page 144) 

2. Registered Permalogs Page (Page 146) 

3. Unregistered Permalogs Page (Page 147) 

4. Search Result Page (Page 148) 

5. Requested Permalog History Page (Page 149) 

See Figure 121: 

 

Figure 121: PermaHOST Summary Screen – Devices Administration Page - Total Permalogs 

Page 
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Devices Administration Page – Total Permalogs Page 

Figure 121 shows the Total Permalogs Page within the Devices Administration Page.  

Table 18 explains the individual columns shown in the Total Permalogs Page within 

the Devices Administration Page.  

The user will be able to sort the column by ascending/descending order by clicking on 

a column heading.  

Note that when the user chooses to use the “Search For” option within this dialog box, 

the search result will be displayed in “Search Result” page.  

1. The Recordstextbox will reflect the total number of records being displayed on the 

screen.  

2. The  button will export the displayed list to a CSV formatted file.  

2.1. See Figure 122. 

3. The “Search For” Option will allow the user to search by: 

3.1. Serial Alphabet – All available active serial alphabets in the database will be 

displayed in the combo list next to the “Search For”search for combo list.  

3.2. Last Msg Date – The user can select from the search combo box the list of 

available last message dates.   

3.3. Location Number - All available Location Numbers in the database will be 

displayed in the combo list next to the “Search For” combo list.  

3.4. Address 1 – All available Address 1 in the database will be displayed in the 

combo list next to the “Search For” combo list. 

3.5. Address 2 - All available Address 2 in the database will be displayed in the 

combo list next to the “Search For” combo list. 

3.6. Pipe Sensitivity – All available Pipe Sensitivity in the database will be 

displayed in the combo list next to the “Search For” combo list.  

4. Context Menus: Accessible by right-clicking on a particular Permalog in the list.  

4.1. See Summary Screen – Devices Administration Page and Sensors Page 

Context Menu Options (Page 133) 
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Table 18: Columns for PermaHOST Summary Screen – Devices Administration Page – 

Total/Registered/Unregistered Permalogs Page (Also include Search Result Page) 

Serial Alphabet The Permalog logger Serial number with its unique alphabet 

identification. 

Last Message This indicates the date the Permalog last received a GNET 

message. 

Deployed  This indicates the date the Permalog was first entered into the 

database. 

Pipe Sensitivity The sensitivity of the pipe, ranging from 50% to 150% 

sensitivity.  

If the Pipe Sensitivity is not default 100% sensitivity, the leak 

status of the logger is calculated by PermaHOST. 

Location Number The P+ Status information: Location Number 

Address 1 The P+ Status information: Address 1 

Address 2 The P+ Status information: Address 2 

Notes The P+ Status information: Additional information  

 

 
Figure 122: Summary Screen – Devices Administration – Total Permalogs - Export to CSV 
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Devices Administration Page – Registered Permalogs Page 

Figure 123 shows the Registered Permalogs Page within the Devices Administration 

page.  

Table 18 explains the individual columns shown in the Registered Permalogs Page 

within Devices Administration Page.  

All functionality in this page is the same as those described in Devices Administration 

Page – Total Permalogs Page. 

 

Note that in the PermaHOST Summary Screen, a Permalog is considered registered if 

one of the following columns is not empty: 

1. Location Number 

2. Address 1 

3. Address 2 

 

Figure 123: PermaHOST Summary Screen – Devices Administration Page - Registered 

Permalogs Page 
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Devices Administration Page – Unregistered/New Permalogs Page 

Figure 124 shows the Unregistered/New Permalogs Page within the Devices 

Administration Page.  

Table 18 explains the individual columns shown in the Unregistered/New Permalogs 

Page within the Devices Administration Page.  

All functionality in this page is the same as those described in Devices Administration 

Page – Total Permalogs Page. 

Note that in the PermaHOST Summary Screen, a Permalog is considered 

unregistered/new if all of the following columns are empty: 

1. Location Number 

2. Address 1 

3. Address 2 

 
Figure 124: PermaHOST Summary Screen – Devices Administration Page - Unregistered/New 

Permalogs Page 
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Devices Administration Page – Search Result Page 

Figure 125 shows the Search Result Page within the Devices Administration Page. 

Table 18 explains the individual columns shown in the Search Result Page within the 

Devices Administration Page.  

All functionality in this page is almost the same as those described in Devices 

Administration Page – Total Permalogs Page, with the exception of “Search For” and the 

 button. 

The “Search For” function is replaced with “Search Result for”. The option the user 

chooses to search by in the previous page will be shown on this page. For example, in 

Figure 125 in the Total Permalogs Page, the user has chosen to search for Pipe 

Sensitivity at 150% Custom Pipe Type.  

The  button will return to user to the page before the search result was 

called.  

 

Figure 125: PermaHOST Summary Screen – Devices Administration Page - Search Result Page 
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Devices Administration Page – Requested Permalog History Page 

Figure 126 shows the Requested Permalog History Page within the Devices 

Administration Page. The functionality of this page is the same as in Sensors Page – 

Requested Permalog History Page, and hence will not be elaborated further.  

 

Figure 126: PermaHOST Summary Screen – Devices Administration Page - Requested Permalog 

History Page
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 Setup PermaNet SMS Dialog Explained 

 

Figure 127: Setup PermaNet SMS Screen 

 

List Box “Permalog Loggers Linked” 

Displays all Permalog loggers Serial Number, linked to the same PermaNet SMS: 

Note: To link a Permalog+ logger to a PermaNet SMS, the user must either: 

• Enter the PermaNet SMS Telephone number when Adding a New Logger, or 

• Go to Modify Logger Details to add a PermaNet SMS Telephone number 

If at least one Permalog logger is listed, the user could double-click the logger to 

modify its status directly.  

If there is more than one Permalog logger listed, selecting a different logger in the list 

will reflect its unique PermaNet SMS Information on the screen. (Note: This 

information is different to that of the logger status). 

 

Group “Update PermaNet SMS Information”  

This option is only enabled for editing (read-only otherwise) when the user right-

clicks a Permalog+ Logger in Location Pane->Setup PermaNet SMS. 

Note: The user must at least link the Permalog+ logger to a PermaNet SMS before 

proceeding. To do so, the user must either: 
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• Enter the PermaNet SMS Telephone number when Adding a New Logger, or 

• Go to Modify Logger Details to add a PermaNet SMS Telephone number 

• Or if using PermaHOST Version 3.80 and above, wait for the PermaNet SMS 

Configurations to be automatically filled in on the second report day. Version 

3.80 will auto-fill the PermaNet SIM and Serial number into the logger details 

automatically upon a GNET message being received.   

Everything within this group (Update PermaNet SMS Information) is unique to the 

specified Permalog+ logger. 

1. Address 1 

2. Address 2 

3. Note 

 

To save the unique PermaNet SMS Details for a specified Permalog+ Logger, the user 

must click the  button. 

 

To delete the unique PermaNet SMS Details for a specified Permalog+ Logger, the 

user must click the  button. 

 

Group “Permalog Loggers Linked” 

Everything within this group is common to all Permalog loggers linked to the same 

PermaNet SMS.  

Note: From application release Version 3.40 onwards, it is not necessary for a 

PermaNet SMS to be linked to a Permalog+. A PermaNet SMS can now exist without 

being linked to any Permalog+ logger.  

Note: From application release Version 3.80 onwards, it is no longer necessary for the 

user to manually link the PermaNet SMS to the Permalog. PermaHOST is now 

capable of filling in this information automatically if the information is available to 

PermaHOST.  

 

Group “Current/Pending Setup Display selection” 

The default selected option is always “Current PermaNet SMS Settings”. 
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If “Pending PermaNet SMS Settings” is available, the option will be enabled, and the 

user will be able to view the Pending PermaNet SMS Settings.  

The user can delete either the Current or Pending configuration by clicking the 

 button. 

If deleting the Current PermaNet SMS Settings, the selected PermaNet SMS 

Configuration settings will be removed permanently.  

If deleting the Pending PermaNet Settings, the selected PermaNet SMS Pending 

Configuration settings will be removed permanently.  

 

Group “PermaNet SMS Type (Required to know how to handle GNET 

messages)” 

 
 

The default selected radio button is “PALMER” for a new Setup. This is changeable 

by the user, or by the Application itself, depending on the type of PermaNet SMS 

Configuration message received. It is crucial that if the user is to configure this value, 

that they know the version number of their PermaNet SMS. For PermaNet SMS 

Version below “Ver 01.00.03.00” or Radio-Tech Concentrator, the contents of the 

GNET message will not be extracted fully.  

If the PermaNet SMS has not been added to the PermaNet SMS table, the GNET 

message will not be extracted fully. 

 

Note: From Version 3.80 onwards, if the PermaNet SMS has not been added to the 

PermaNET SMS table, PermaHOST will auto-send a GET CONFIG message upon 

receiving the GNET message. On the next report day, the PermaNet SMS 

Configuration response sms will populate the database automatically. If the PermaNet 

SMS has firmware version from Ver 01.00.03.00, it will be assigned “PALMER”, in 

which case the full GNET message content will be extracted.  

Also to note, the GET CONFIG message will only be sent once automatically by 

PermaHOST, this is to prevent SMS wastage if more than one logger is linked to the 

same PermaNet SMS.  
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Group “Report Staggering” 

 
 

From PermaHOST version 3.80 onwards, report staggering is a configuration that the 

user could set for a PermaNet SMS. This code will work with PermaNet SMS 

firmware version from 01.00.03.01 onwards.  

This feature is used to delay the Data Report time by xxx seconds defined by the user. 

Please see the image above for report staggering time calculations.  

 

Open Configuration File 

The button allows the user to open an “.ini” 

configuration file to fill in: 

1. Host PC Telephone Number (NUM1) 

2. NUM2 

3. Patrol Days 

4. Data Report Days 

5. Patrol Start Time 

6. Patrol Duration 

7. Data Report Time 

8. Report Staggering. Significant digits of PermaNet SMS Serial Number to use 

9. Report Staggering. Time Offset 

10. File Pathname 

 

Save Configuration File 

The  button allows the user to save the 

configuration detailed above to an “.ini” file.  

Note: All fields could be empty and the user could save an empty “.ini” file.  
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Change PermaNet SMS Configuration (Update to Current Database Only) 

  

If the check box is checked and the user clicks “OK”, the Configuration Details will 

be updated to the Current database. The user will use this option if the PermaNet SMS 

has already been setup and the user only wanted to manually update the database with 

the known PermaNet SMS Configurations.  

Note: The user could overwrite the Current or Pending database without using the 

“Delete SMS Settings”.  To do so, the user should check one of the checkboxes, either 

“Change PermaNet SMS Configuration (Update to Current Database Only)” or 

“Change PermaNet SMS Configuration (Update to Pending database Send SMS)”.  

It is strongly recommended that the user uses the Data Pane->Send SMS to get 

PermaNet SMS Configuration option instead of manual entry.  

 

Change PermaNet SMS Configuration (Update to Pending Database Send SMS) 

  
If the check box is checked and the user clicks “OK”, the Configuration Details will 

be updated to the Pending Database and a configuration test message will be sent out 

to the PermaNet SMS.  

Note: The user could overwrite the Current or Pending database without using the 

“Delete SMS Settings”. The required element to do so is to tick the check boxes.  

When a response is received from the PermaNet SMS, the following procedure will 

be performed. 

1. The content of the Pending database will be compared with the received PermaNet 

SMS configuration message. 

1.1. If matched, the configuration will be copied into the Current Database.  

1.2. The content of the Pending Database will be deleted.  

2. If the content of the Pending Database does not match the received SMS 

configuration text.  

2.1. The configuration will be copied to the Current Database.  

2.2. The Unmatched Pending Configuration for the particular PermaNet SMS will 

be resent. Note the Application will attempt to resend up to 3 times, thereafter 

the user will be informed with a pop up box that the pending configuration 

has not been matched after 3 attempts and sending will not be reattempted.  
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2.3. The Pending database remains until it is: 

2.3.1. Overwritten 

2.3.2. Deleted manually by user 

2.3.3. Deleted when a matching configuration response has been received.  

 

OK  

If the user clicks the  button without checking either “Change PermaNet 

SMS Configuration (Update to Current Database Only)” or “Change PermaNet SMS 

Configuration (Update to Pending Database Send SMS)”, the dialog box will  close 

without performing the update to current or pending database. No configuration 

message will be sent out to the PermaNet SMS.  

 

Cancel 

If the user clicks the  button, the dialog box will close without performing 

update configuration information to either pending or current database, even if the 

checkboxes are checked.  

 

NOTE: The minimum requirement to assign a PermaNet SMS to a Permalog 

Logger is to enter the “PermaNet SMS Telephone Number”. 

To assign a Permalog+ to a PermaNet SMS, go to: Location Pane->Modify 

Logger Details 

The user should enter the PermaNet SMS Telephone number in the correct 

format, with or without county code; this depends on individual network in each 

country.  

 

Note: With PermaHOST Version 3.80 onwards, it is no longer necessary for the 

user to manually assign a Permalog to a PermaNet SMS.  
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 Authorisation Code 

 

The Authorisation Code is currently unchangeable.  

Authorisation Code: 190020373 
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Contact 

 

HWM-Water Ltd 

(Palmer Environmental) 

Ty Coch House 

Llantarnam Park Way 

Cwmbran 

Gwent 

NP44 3AW 

United Kingdom 

 

Tel: +44 (0) 1633 489479 

Fax: +44 (0) 1633 877857 

 

General Enquires: sales@hwm-water.com 

Technical support: info@hwm-water.com 

 

Web: http://www.hwm-water.com 

 

Note 

HWM-Water Ltd reserves the right to change products, services or specifications 

without notice. 

 

Patents 

The Permalog® system is patented in the United Kingdom: 

GB2335041, GB2361062, GB2361319, GB2361540 & GB2361541 

Patents pending in Europe, United States and Japan. 

Permalog® is a Registered Trademark of Palmer Environmental. 

 


