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Introduction 

This document outlines the new features implemented into the Smart Patrol PC software 

v4.0.0.0 or later.  

The document also describes all changes made to the existing functions found in previ-

ous versions  

 

Compatibility 

The software is compatible with v7 USB Transceivers or later. However some of the 

added features implemented will not be available if used with USB Transceiver version 

prior to version 7.  

 

The new software is compatible with all versions of logger. Loggers that are version 3 or 

earlier can not be used with any software feature that requires a request for individual 

data packets. 

 

Meter Detail and Meter Data export csv files generated by Smart Patrol v3.2.4 or earlier 

will NOT import into Smart Patrol v4 or later. 

 

Drive-By round export csv files will import and export across all versions of Smart Patrol 
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USB Transceiver Connection Process 

1. USB Transceiver connection 

The software no longer automatically connects to the USB Transceiver on start-up. To 

connect to the USB transceiver, plug in the transceiver to the PC then on the software 

click File->Connect.  

 

 

 

 

 

 

 

 

 

 

 

The message ‘Searching ports to connect’ will appear in the main form status bar  

 

When the USB Transceiver connects the message USB connected will appear in the 

tool bar menu. Once connected the chip list will begin to fill with received chirps from 

loggers currently in RF range. 

 

 

 

To disconnect click File->Disconnect  

 

If you attempt to connect to the USB Transceiver with no Transceiver connected the 

software will continually attempt to connect until a USB transceiver is connected. 

There maybe a reduction in software performance whilst trying to connect to the USB 

transceiver. It is recommended to only connect to the USB Transceiver when a trans-

ceiver is plugged into the PC 
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Data Download Process 

 

Historical Meter Reading Downloading  

Smart Patrol will now only store data from the last download for each logger . Any ex-

isting data found in the Smart Patrol database from a previous download will automat-

ically be deleted when downloading that same logger again.  This change does not af-

fect the logger information details (Meter ID, Address etc..)  

 

To save previous downloads the user must ensure that downloaded data has been ex-

ported to (*.csv) file first before re-downloading an individual logger. 

 

Current Meter Reading Only Download 

Any Smart Patrol Import (*.sif) file that is imported into Smart Patrol will overwrite 

the meter readings currently stored in the database with the reading stored on the 

(*.sif) file 

 

  It is recommended at the end of the meter reading patrol to recreate the (*.sif) file 

with the meter information containing the updated meter readings.  

 

To export the meter readings into one (*.csv) file use ‘Export Meter Details’ with the 

(*.csv) file type selected.   See ‘Export Dialog‘ below 

 

The meter readings can also be exported using ‘Export Meter Data’ as with the histori-

cal data download, However each reading will be exported into a separate file for each 

meter.  
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CSV File System 

 

The Smart Patrol Software database is now made up of a CSV file based system. This 

system allows quicker access when searching and exporting data and also is capable 

of storing large quantities of data. 

 

The CSV file system is stored in two folders in the Smart Patrol working directory 

 

<InformationStore>  

This folder contains all data relating to Meter and Logger details.  

 

<DataStore> 

This folder contains all data relating to the downloaded data 

 

These files are only accessed via the Smart Patrol Software and should not be ac-

cessed by the user directly 
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Database Manager 

 

The database manager will be used to manage the csv files making up the database  

 

Current features available are listed below 

 

 

 

 

 

 

 

 

 

Clear All Downloaded Data  

This clears all downloaded data from the database. All meter and logger and drive-by 

details are retained 

 

Clear Drive-By Rounds 

This clears all the data relating to drive-by routes and rounds. All downloaded data  

and  meter and logger details are retained 

 

Clear Entire Database 

This function deletes all Meter/Logger, drive-by and downloaded data held in the data-

base. This feature is used to blank a database 

 

Any data that is deleted using any of the above options cannot be retrieved once dele-

tion is complete 
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Import Dialog  

The software is able to import two file types 

Meter / Logger Details —  as (*.sif) Files 

Drive-by Round Details — as  (*.csv) Files 

 

To import a file click File->Import 

 

 

 

 

 

 

 

 

 

 

 

 

In the open dialog select the file type for the file you want to import  

For Meter / Logger Details select (*.sif) 

For Drive-by Round Details select (*.csv) 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

Once selected click open to start the import dialog  
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Import Dialog Cont’d 

 

 

 

 

 

 

 

 

 

The import dialog has the following features 

 

Include DriveByRounds  

If this is ticked when ‘Import’ button is clicked the Smart Patrol Software will import 

both the Meter/Logger details and the drive-by round details together. The drive-by  

details file (*.csv) to be imported must have the same filename as the Meter/Logger 

details file  (*.sif). Both files must also be located in the same folder. With this check 

box checked both files must be located successfully for any data to be imported 

 

Example  

    <DriveRoundImportFolder> 

                        - ImportedData.sif  -  file containing Meter/Logger details 

                        - ImportedData.csv  - file containing drive-by details    

 

Import Policy 

Remove all existing meters and replace with imported meters 

   Selecting this policy will clear the database before importing the data. The database 

will just contain the imported data 

 

Replace or add the imported meters retaining all other meters 

Selecting this policy will update any existing meter entry in the database with the data 

found in the import file. If the imported file contains meters not found in the main da-

tabase then these meters will be added to the database. No changes will be made to 

all other meters found in the database 

 

When importing Smart Patrol import file (*.sif)  the current meter reading will always 

be updated with the reading stored in the (*.sif) file. Please ensure that any (*.sif)  

file being imported contains the latest meter readings. 
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Export Dialog  

The export dialog is used to export files for the following  

 

<Specified Filename>.sif -  file to export meter and logger details 

<Specified Filename>.csv -  file to export driveby details  

<Specified Filename>.csv -  file to export custom csv file as per CSV FileSetup dialog           

- this can be used to import into external software or used for reporting purposes 

 

The following lists the type of exports 

 

 

 

 

 

 

 

 

 

 

Export Meter Details 

Select this when exporting Meter/Logger Details 

 

Export Meter Data 

Select this when exporting downloaded data 

 

Exporting Driveby Rounds  

Select this when exporting the drive-by details to be re-imported back into Smart pa-

trol (*.csv) file. The headers in this file are fixed and cannot be changed by the CSV 

File Setup dialog 

 

CSV File Setup 

Select this to setup the csv file export headers for meter details and meter data csv 

file exports 



11 

 

Export Details Dialog 

 

 

 

 

 

 

 

The Export Meter Details has the following features 

Meter Selection 

Meters to be exported can be grouped by  

• Driveby— Meters listed for a particular drive-by round 

• Meter— lists all meters in the database 

• Selected—Lists meters that have been highlighted on the main form 

 When a group is selected the selection dropdown box will contain the individual selec-

tions for that group. Select ‘ALL’ to export the entire meter group 

Include DriveByRounds Details 

If this box is ticked when the Export button is pressed then the drive-by rounds file 

will also be exported with the meter details. Both files will be given the same filename 

specified by the user. 

Do not check this box if you are exporting meter details as a csv file  

Files will be saved at… 

Filename—Either user the browse button to enter a location file path or the path can be typed 

manually 

Exported Type—Specifies two export types 

Smart Patrol Import File (*.sif)  -  File to be imported back into Smart Patrol 

Comma Separated Values (*.csv)  - Export file as setup by the CSV File Setup dialog 
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Export Data Dialog 

 

 

 

 

 

 

 

 

The Export Meter Data has the following features 

Meter Selection 

Meters to be exported can be grouped by  

• Driveby— Meters listed for a particular drive-by round 

• Meter— lists all meters in the database 

• Selected—Lists meters that have been highlighted on the main form 

 When a group is selected the selection dropdown box will contain the individual selec-

tions for that group. Select ‘ALL’ to export the entire meter group 

Include DriveByRounds Details 

This must be unchecked to export meter data 

Data Range 

Either specify a date range to be export or click ‘Export All Data’ to export all stored 

data.  

Files will be saved at… 

Filename — Specify a folder to export the data. Folders can be specified either by using the 

browse button or by manually typing the location path. Do not add a ‘\’ at the end of the fold-

er name 

Exported Type — Comma Separated Values (*.csv)  - Data files will be exported as setup by 

the CSV File Setup dialog 
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CSV File Setup 

 

 

 

 

 

 

 

 

 

 

 

The above dialog allows the user to select what data is to be exported when selecting 

to export by csv file type. 

Export Type 

Meter Details Export — click this to select the data to be exported when exporting Me-

ter/Logger Details 

Meter Data Export — click this to select the data to be exported when exporting the 

downloaded data 

List of Headers 

Available Headers — This lists the data headers that can be selected for the export 

file. This list will change depending on the export type selected above 

Selected Headers 

This list of headers is the current selection for the export file.  

To add or remove a data header either double click on that header or use the arrow 

buttons, The double arrow button removes all headers from the Selected Header List.   

Headers that are listed at the top of the Selected Header list will appear as the left 

most column on the exported CSV 
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Drive-by Right Click Menu 

 

When performing a drive-by right clicking on a particular meter entry will give you the follow-

ing menu options 

Manually Enter Meter Reading 

This allows the user to manually enter a meter reading.  The time logged will be the time the  

reading is entered. Once the reading is entered and OK is clicked the meter entry will be 

flagged as ’Read’ and removed from the drive-by list  

Edit Meter / Logger Details 

This allows the user to edit the details of a particular meter without reverting back to the 

main screen. Any changes made will immediately update in the database but the drive-by 

screen will only update when restarted. Enter the password  ‘radiotech’ if prompted to access 

this dialog 

Ignore  

This moves the meter entry to the bottom of the drive-by list, allowing the next meter to 

begin downloading. This does not change the entries original sequence number so will be re 

placed if the drive-by window is restarted 
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RF Signal Strength Indication 

 

When a logger sends a chirp to the USB Transceiver. The transceiver takes a meas-

urement of the signal power for that chirp. This value can be used to assess the RF 

signal quality from an individual logger. 

The scale of the RF strength value is between 0 – 100. The higher the signal value the 

stronger the signal strength. Any value over 50 is deemed to be a good enough signal 

for downloading.  

The RF signal strength values are shown in ‘RF Signal’ column on the chirp list on the 

main form 

 

 

 

 

 

 

 

 

 

Also on the drive-by screen in the ‘Signal ‘column 

 

 

 

 

 

The ‘Signal’ value will only update when a chirp is received from that logger. 

These values are for indication purposes only 
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RF Test Screen 

To start the RF Test Screen click Tools->RF Test Screen 

 

 

 

 

 

 

This screen allows the user to perform checks on the RF Communication between log-

ger and USB Transceiver at either logger installation time or when performing diag-

nostic checks.  

The RF Test Screen allows the user to view the incoming chirps from a particular log-

ger. To begin type in the logger ID number to be tested into the menu bar Logger ID 

Text box.  

Then click on ‘Start Capture’ to start viewing the incoming chirps. The chirp when re-

ceived displays the following information 

Logger ID — Logger ID that transmitted the chirp 

Packet — The type of packet identified  

Time — the time the chirp was received as hours:mins:secs,millisecs 

Chirp Type – The type of chirp identified to indicate message size 

RSSI — the dBm value of the chirp received read by the USB Transceiver. To convert 

this to the 0-100 scaling factor ( dBm value + 120 ). The scaling value is capped at 0 

and 100 
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RF Test Screen Cont’d 

 

The RF Test Screen has the facility to perform a test download . This test is to contin-

ually request 4 week of data from the logger. This test will always download 4 weeks 

of data and will disregard the weeks value entered in the ’Options’ dialog. This test 

can be used at either logger installation or diagnosing problems to ensure a robust 

data download.  

To begin the test type the logger ID to be tested into the Logger ID text box and click 

‘Start Capture’. When chirps begin to be received click ‘Download Test Stopped’. The 

 

download will start when the logger receives the download command just after its 

transmitted a chirp message. The logger is then continually requested for 4weeks of 

data. To stop the test click ‘Download Test Running’ on the menu bar 

The download test is considered good if most or all packets are received after each request. A 

poor download can be expected if a large percentage of packets are continually not being re-

ceived with each request 
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Smartlog Configuration Screen 

 

Smart Patrol now has the facility to change various Smartlog parameters whist the 

loggers are installed in the field.  

To change a Smartlog configuration. Ensure the USB Transceiver is connected. Open 

the Smartlog edit dialog by highlighting a Smartlog to be changed on the main data-

base screen then click Edit->Edit logger / Meter Details.  When asked for a password  

type “radiotech” disregarding the quotes 

On the edit form click the SMARTlog configuration button to open the configuration di-

alog.  Click yes to the “Are you sure?” message to confirm you want to make a 

change to that Smartlog 

Below lists the various parameters currently available   

1. Changing the Sample Rate 

Smart Patrol can change the time period that the Smartlog stores a reading for the 

historical data download.  

 

 

 

 

 

 

Select the Memory Configuration tab and then in “New Sample Period” select the de-

sired sample period from the drop down list and click the “Enable” checkbox. Ensure 

the Erase Logger Memory Enable checkbox is unchecked if you do not wish to clear 

the SMARTlog memory in the same request when clicking the send button.  Then click 

“send“ to transmit the command. When the logger next chirps, the command will be 

sent to the SMARTlog.  The  “Current Sample Period“ will change when the SMARTLog 

successfully changes it’s sample rate.   

If the sample period is changed without clearing the SMARTlog memory, you must 

wait until 48Hrs worth of data has been collected on the new sample rate before 

downloading   
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Smartlog Configuration Screen Cont’d 

 

2. Erasing the SMARTLog History 

Smart Patrol has the capability to erase the SMARTLOG history and set the logger 

reading to zero  

 

 

 

 

 

 

 

 

 

Select the Memory Configuration tab and then in the “Erase Logger Memory” select 

click the “Enable” checkbox. If you do not wish to change the Sample Period in the 

same request then ensure the Change Sample Period Enable check box is unchecked 

before clicking “Send”. When the logger next chirps, the command will be sent to the 

SMARTlog.  The Current Reading value will change to zero when the command is suc-

cessful 
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Smartlog Configuration Screen Cont’d 

 

2. Pressure Calibration 

This feature is only for use with pressure SMARTlog. This feature allows the Smartlog 

to be calibrated on known pressure readings 

 

 

 

 

 

 

 

 

 

Select the Pressure Calibration tab to view the calibration screen. 

First select how many calibrations points to use. All  Smartlogs must have a zero cali-

bration and at least one calibration reference point. The reference point does not have 

to be the maximum pressure value expected but must be above zero . With the cali-

bration readings as a reference all other readings will then be based on these readings 

Example 

If a known pressure level when calibrating was set to 100dm.  Dropping the pressure 

by half with reference to zero will give a reading of 50dm 

If the same pressure level when calibrating was set to 50dm. Dropping the pressure 

to the same half level will give a reading of 25dm 
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Smartlog Configuration Screen Cont’d 

 

2. Pressure Calibration 

To calibrate the zero value connect a pressure value of 0dm to the SMARTLog trans-

ducer, and then click Calibrate Zero Reading. The reading recorded on the transducer  

at that moment will be used as the zero reference for all other readings. 

To calibrate at a given reference point, apply a known pressure onto the transducer, 

and then enter that value in decimetres into the calibration point . Click calibrate to 

use the current reading as a reference point. 

To confirm the readings click the Memory Configuration tab and view the Current 

Reading value being transmitted from the SMARTlog. The current reading will update 

every 2 seconds for 60 chirps after the calibration command and then every 30 se-

conds thereafter.  
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USB Transceiver Upgrade 

 

Smart Patrol has the facility to upgrade the USB Transceiver unit over the USB link. 

There are two ways that the upgrade can be started  

1. Automatically upgrade on USB Connection 

 

 

 

 

 

 

 

 

 

If the “Automatically Upgrade USB Transceiver” checkbox is checked in the Options 

dialog. Any USB Transceiver that connects to Smart Patrol, if the version number of 

the Transceiver is out of date then Smart Patrol will automatically upgrade the Trans-

ceiver to the latest version stored in that version of Smart Patrol.  

USB Transceivers earlier than v11 do not have upgrading via USB capability. So to 

use a previous versions of Transceiver with the latest Smart Patrol ensure the 

“Automatically Upgrade USB Transceiver “is unchecked before connecting the Trans-

ceiver. 

2. By Menu Selection 

The USB Upgrade can also be started by menu selection in Tool->Upgrade USB Transceiver 

When selecting this menu option the 4 status Led’s on the left hand side of the USB Trans-

ceiver will begin flashing and the USB link will disconnect. To start the upgrade ensure 

“Automatically Upgrade USB Transceiver” is checked in the Options menu in Smart 

Patrol as above and then connect the USB by clicking “USB Disconnected” icon  
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USB Transceiver Upgrade Cont’d 

 

Upgrading Process 

 

 

 

 

 

 

The upgrading process begins with a message notifying the user not to unplug the 

USB transceiver until the upgrade is complete. Click OK to confirm this message and 

the upgrade will begin. 

 

 

 

 

 

Upgrade progress is then shown via the progress bar. The upgrading cannot be can-

celled once the process has started. The user will be notified when the upgrade com-

pletes.  

At the end of the upgrade process the Transceiver will restart automatically.   


